#9428 [Com]: CGI error when executing php script in a virtual directory

From: Date: Fri, 30 Aug 2002 08:17:09 +0000
Subject: #9428 [Com]: CGI error when executing php script in a virtual directory
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18224@lists.php.net to get a copy of this message
ID: 9428 Comment by: t.cannaerts@unec.be.remove.this.bit Reported By: kevin@ig.utexas.edu Status: No Feedback Bug Type: IIS related Operating System: NT4 SP6 PHP Version: 4.0.4pl1 New Comment: I have the same problem with IIS5 on Win2K, PHP 4.2.2. This isn't a virtual directory (VD) problem, though it is often experienced when adding a VD. This occurs when you are trying to access a page to which the Internet Guest account (IUSR_SERVERNAME) doesn't have any rights to. This means you need to set NT-permissions on the physical folder where the files reside, which is often forgotten when creating a VD. I don't know why or who (PHP, IIS?) returns the header, but it should return a permission denied instead. Hope this info helps. Previous Comments: ------------------------------------------------------------------------ [2002-02-02 06:41:21] sander@php.net No feedback was provided for this bug, so it is being suspended. If you are able to provide the information that was requested, please do so and change the status of the bug back to "Open". ------------------------------------------------------------------------ [2002-01-12 06:56:32] lobbin@php.net Can you reproduce this with 4.1.1? ------------------------------------------------------------------------ [2001-02-23 13:17:53] kevin@ig.utexas.edu I have PHP 4.0.4pl1 installed on an NT4 (SP6) Server running IIS 4.0. Executing PHP scripts in a directory under www_root works fine. When the simplest helloworld script is executed on a virtual directory, I get "The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:" I've tried telnetting to the server and getting the file to see what headers are returned: HTTP/1.1 502 Gateway Error Server: Microsoft-IIS/4.0 Date: Fri, 23 Feb 2001 18:10:22 GMT Content-Length: 215 Content-Type: text/html <head><title>Error in CGI Application</title></head> <body><h1>CGI Error</h1>The specified CGI application misbehaved by not returning a complete set of HTTP headers. The headers it did return are:<p><p><pre></pre>Connection closed by foreign host. I've seen a couple of references to this problem on php.net, but no solutions. Any ideas? Thanks. Kevin Johnson ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=9428&edit=1

« previous php.bugs (#18224) next »