Bug #65933 [NEW]: Cannot specify config lines longer than 1024 bytes
| From: | daverandom@php.net | Date: | Sun, 20 Oct 2013 21:56:38 +0000 |
| Subject: | Bug #65933 [NEW]: Cannot specify config lines longer than 1024 bytes | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-182350@lists.php.net to get a copy of this message | ||
From: daverandom@php.net
Operating system: Any
PHP version: Irrelevant
Package: FPM related
Bug Type: Bug
Bug description:Cannot specify config lines longer than 1024 bytes
Description:
------------
Configuration lines cannot be longer than 1024 bytes because the file
read buffer is hard-set to this size.
http://lxr.php.net/xref/PHP_5_5/sapi/fpm/fpm/fpm_conf.c#1468
Ref of this problem in the real world:
http://serverfault.com/questions/547394/is-there-a-limit-setting-a-php-admin-value-in-php-fpm
Test script:
---------------
disable_functions =
dl,exec,passthru,shell_exec,system,proc_open,popen,curl_exec,curl_multi_exec,parse_ini_file,show_source,pcntl_exec,include,include_once,require,require_once,posix_mkfifo,posix_getlogin,posix_ttyname,getenv,get_current_use,proc_get_status,get_cfg_va,disk_free_space,disk_total_space,diskfreespace,getcwd,getlastmo,getmygid,getmyinode,getmypid,getmyuid,ini_set,mail,proc_nice,proc_terminate,proc_close,pfsockopen,fsockopen,apache_child_terminate,posix_kill,posix_mkfifo,posix_setpgid,posix_setsid,posix_setuid,fopen,tmpfile,bzopen,gzopen,chgrp,chmod,chown,copy,file_put_contents,lchgrp,lchown,link,mkdi,move_uploaded_file,rename,rmdi,symlink,tempnam,touch,unlink,iptcembed,ftp_get,ftp_nb_get,file_exists,file_get_contents,file,fileatime,filectime,filegroup,fileinode,filemtime,fileowne,fileperms,filesize,filetype,glob,is_di,is_executable,is_file,is_link,is_readable,is_uploaded_file,is_writable,is_writeable,linkinfo,lstat,parse_ini_file,pathinfo,readfile,readlink,realpath,stat,gzfile,create_function,phpinfo
Expected result:
----------------
php-fpm will start successfully
Actual result:
--------------
[20-Oct-2013 22:31:52] ERROR: [/file.conf:line] value is NULL for a
ZEND_INI_PARSER_ENTRY
[20-Oct-2013 22:31:52] ERROR: failed to load configuration file
'/file.conf'
[20-Oct-2013 22:31:52] ERROR: FPM initialization failed
--
Edit bug report at https://bugs.php.net/bug.php?id=65933&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=65933&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=65933&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=65933&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=65933&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=65933&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=65933&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=65933&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=65933&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=65933&r=support
Expected behavior: https://bugs.php.net/fix.php?id=65933&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=65933&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=65933&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=65933&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=65933&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=65933&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=65933&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=65933&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=65933&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=65933&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=65933&r=mysqlcfg