Bug #66301 [Com]: Cannot load php5apache2_4.dll into server: Access is denied
| From: | michael at squiloople dot com | Date: | Wed, 18 Dec 2013 16:05:42 +0000 |
| Subject: | Bug #66301 [Com]: Cannot load php5apache2_4.dll into server: Access is denied | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-183394@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=66301&edit=1
ID: 66301
Comment by: michael at squiloople dot com
Reported by: michael at squiloople dot com
Summary: Cannot load php5apache2_4.dll into server: Access is
denied
Status: Open
Type: Bug
Package: Apache2 related
Operating System: Windows Vista SP 2
PHP Version: 5.5.7
Block user comment: N
Private report: N
New Comment:
Replacing php5ts.dll with the version from 5.5.3 allows Apache to run 5.5.7, again suggesting that
there is some fundamental permission error with the version starting 5.5.4 (the file cannot be
opened or copied even when "run as administrator").
Previous Comments:
------------------------------------------------------------------------
[2013-12-17 18:19:41] michael at squiloople dot com
Apache 2.4.7 (https://www.apachelounge.com/download/VC11/binaries/httpd-2.4.7-win32-VC11.zip) cannot
load php5apache2_4.dll into server. The specific error is:
"Syntax error on line 176 of C:/Apache/conf/httpd.conf: Cannot load C:/PHP/php5apache2_4.dll
into server: Access is denied. ."
This issue also occurs in PHP 5.5.6, 5.5.5, and 5.5.4. It does not occur in 5.5.3.
In all cases the Win32 VC11 x86 Thread Safe builds were used.
Using the Dependency Walker the issue seems to be with php5ts.dll; access is denied to
php5apache2_4.dll when trying to open it. When trying to open php5ts.dll with the Dependency Walker,
even when run as an Administrator, I'm given the Windows alert "You don't have
permission to open this file". This suggests that php5ts.dll has been created with the wrong
permissions.
------------------------------------------------------------------------
[2013-12-16 15:11:52] michael at squiloople dot com
Description:
------------
Apache 2.4.7 (https://www.apachelounge.com/download/VC11/binaries/httpd-2.4.7-win32-VC11.zip) cannot
load php5apache2_4.dll into server. The specific error is:
"Syntax error on line 176 of C:/Apache/conf/httpd.conf: Cannot load C:/PHP/php5apache2_4.dll
into server: Access is denied. ."
This issue also occurs in PHP 5.5.6, 5.5.5, and 5.5.4. It does not occur in 5.5.3.
In all cases the Win32 VC11 x86 Thread Safe builds were used.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=66301&edit=1