Bug #15910 Updated: php-3.0.18 configure --with-pgsql=DIRWITH-FOO
| From: | sniper@php.net | Date: | Wed, 06 Mar 2002 21:45:22 +0000 |
| Subject: | Bug #15910 Updated: php-3.0.18 configure --with-pgsql=DIRWITH-FOO | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-1836@lists.php.net to get a copy of this message | ||
ID: 15910
Updated by: sniper@php.net
Reported By: hlehmann@fh-lausitz.de
-Status: Open
+Status: Bogus
Bug Type: PostgreSQL related
Operating System: Sol-8
PHP Version: 4.1.2
New Comment:
Update to PHP 4. PHP 3 is not supported anymore.
Previous Comments:
------------------------------------------------------------------------
[2002-03-06 13:52:17] hlehmann@fh-lausitz.de
ln -s $PrefixPSQL /usr/local/pgsql
OPTIONS="$OPTIONS --with-pgsql=$PrefixPSQL"
...
./configure $OPTIONS
php-3.0.18 $ make
...
gcc -g -O2 -O2 -I. -I. -I../apache_1.3.22/src/include
-I../apache_1.3.22/src
/os/unix -c internal_functions.c -o
internal_functions.o
In file included from internal_functions.c:59:
functions/php3_pgsql.h:46: libpq-fe.h: No such file or directory
functions/php3_pgsql.h:47: libpq/libpq-fs.h: No such file or directory
make: *** [internal_functions.o] Error 1
## Var PrefixPOSTGRES existiert nicht (-> PrefixPSQL)
## -IPOSTGREDIR fehlt
$ find / -name libpq-fs.h
/usr/local/pgsql-7.2/include/libpq/libpq-fs.h
/tmp/postgresql-7.2/src/include/libpq/libpq-fs.h
## Files sind aber da.
## Pfad (LD)? fuer postgresql fehlt.
## -> Fehler in configure-script , Makefile anpassen
## -----------------------
## add -I/usr/local/pgsql-7.2/include to Makefile (INCLUDE=)
## Fehler ist weg, aber die erzeugte Lib funktioniert nicht.
## -----------------------
## Ursache:
## - configure --with-pgsql=/usr/local/pgsql-7.2
## -> generate Makefile mit:
## INCLUDE = -I$(srcdir) -I. -I/usr/local/apache/include
## ## -I$PrefixPSQL/include fehlt
## - configure --with-pgsql=/usr/local/pgsql
## -> generate Makefile mit:
## INCLUDE = -I$(srcdir) -I. -I/usr/local/apache/include
-I/usr/local/pg
sql/include
## ## -I$PrefixPSQL/include ist vorhanden
## -> Fehler in configure
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=15910&edit=1