Bug #64511 [Com]: Strange memory allocation error message spamming

From: Date: Mon, 12 May 2014 13:09:08 +0000
Subject: Bug #64511 [Com]: Strange memory allocation error message spamming
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-185781@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=64511&edit=1

 ID:                 64511
 Comment by:         d dot vergini at gameprog dot it
 Reported by:        psiek at mscgva dot ch
 Summary:            Strange memory allocation error message spamming
 Status:             Open
 Type:               Bug
 Package:            MSSQL related
 Operating System:   ubuntu 12.10
 PHP Version:        5.4.13
 Block user comment: N
 Private report:     N

 New Comment:

Solved for me with latest Debian updates, probably was a bug in a PHP extension...


Previous Comments:
------------------------------------------------------------------------
[2014-04-26 10:13:36] kaido at tradenet dot ee

it's most probably caused by https://bugs.php.net/bug.php?id=67130

------------------------------------------------------------------------
[2014-04-08 13:54:26] d dot vergini at gameprog dot it

same problem here with php 5.4.4-14! false positive, and the query is executed correctly...
please note that "tried to allocate 140429927214120 bytes" is something like 127,5
terabytes... usually bytes exhausted errors try to allocate much smaller memory this is weird...

------------------------------------------------------------------------
[2013-11-22 07:29:18] psiek at mscgva dot ch

Good morning,

We have tested with 5.4.21 and that does not the trick, we still have memory allocation messages.

Regards,

------------------------------------------------------------------------
[2013-11-20 21:08:40] gordon dot stratton at gmail dot com

We experienced this problem on PHP 5.4.4, but it was fixed by upgrading to 5.4.21.

------------------------------------------------------------------------
[2013-07-31 14:30:42] psiek at mscgva dot ch

Hi,

I just added memory_get_usage and memory_get_peak_usage to my script and here is 
the result:

[31-Jul-2013 16:20:56 Europe/Zurich] Script start
[31-Jul-2013 16:20:56 Europe/Zurich] Memory Get Usage: 524288
[31-Jul-2013 16:20:56 Europe/Zurich] Memory Peak Usage: 524288
[31-Jul-2013 16:20:56 Europe/Zurich] Script end
[31-Jul-2013 16:20:56 Europe/Zurich] PHP Fatal error:  Allowed memory size of 
268435456 bytes exhausted (tried to allocate 140188914343656 bytes) in Unknown 
on 
line 0

The problem comes after script execution. Perhaps there is a problem with 
freeing object in memory?

Any idea?

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=64511


-- 
Edit this bug report at https://bugs.php.net/bug.php?id=64511&edit=1


Thread (17 messages)

« previous php.bugs (#185781) next »