#15333 [Com]: strndup access violation
| From: | tshazli at linuxmail dot org | Date: | Sat, 07 Sep 2002 02:08:16 +0000 |
| Subject: | #15333 [Com]: strndup access violation | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-18593@lists.php.net to get a copy of this message | ||
ID: 15333
Comment by: tshazli@linuxmail.org
Reported By: david@harksystems.com
Status: Open
Bug Type: IIS related
Operating System: Windows 2000 Pro
PHP Version: 4.2.1
New Comment:
Ok, here is the thing:
I have 2 servers load balancing each other. had this problem with one
of our servers (PIII dual processor) but not with the other which is a
single processor. I tried to format the server, reinstall everything
all over again, not apply microsoft patches/fixes...etc. still the
problem occurs ONLY on the dual processor server. Then I tried to take
one processor out of that box and guess what...IT worked flawlessly. I
stress tested it with heavy load test for hours and not once I got the
error ever again. I put the processor back to the box and tested it. I
got the error again. I tried that many times. Always get the error with
dual processor but not even once with single processor.
So how to work around the problem? use single processor server.
What causes the problem? dont know..It is between PHP and IIS. I am
trying to find out the problem by debuging the services but if anyone
is interested in reproducing the problem and trying to debug it, use
dual processor with win2000 server and IIS5 with any php ver >=4.2.1
and use ADODB or MSSQL connections. Stress test it and you will get the
error.
Previous Comments:
------------------------------------------------------------------------
[2002-09-05 00:14:11] home@NOSPAMwebpanache.com
Hi,
Just to contribute had PHP with ISAPI dll working fine until a few days
ago.
It seems that applying the lastest Microsoft security fixes created the
problem. The latest applied fix was MS02-048....
------------------------------------------------------------------------
[2002-08-29 08:30:41] jean-francois_larvoire@hp.com
Hello,
I have the same problem too. And it is reproductible.
This is with the ISAPI version of PHP 4.2.2 under Windows XP.
I get the following error message in the XP Error Log, when trying to
access a page from another PC.
A copy of the test file that causes the problem is at
http://jf.larvoire.free.fr/calendrier.php3.
Pressing on the "Next month" button crashes the PHP DLL.
Jean-Francois Larvoire
vvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvvv
The HTTP server encountered an unhandled exception while processing the
ISAPI Application '
php4ts!zend_strndup + 0x2B
+ 0x17C99F70
'.
For additional information specific to this message please visit the
Microsoft Online Support site located at:
http://www.microsoft.com/contentredirect.asp.
For more information, see Help and Support Center at
http://go.microsoft.com/fwlink/events.asp.
^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
------------------------------------------------------------------------
[2002-08-20 20:15:00] stan.noSPAM_@noSPAM_.daft.cc
Win2k Server, latest security patches
IIS 5.0
PHP 4.2.2 ISAPI
Connections to both mySQL, MSSQL.
Cookie and session usage.
The error of which I was receiving after about 15 page views:
"PHP has encountered an Access Violation at 011929AE"
was solved by...
1. updating all DLLs by copying DLLs included with PHP into
C:\winnt\system32
2. having php4isapi.dll in both my ISAPI Filters and Home Directory >
Configuration (under the Site properties)
3. setting Application Protection to Low (IIS Process)
4. restarting the server
After doing the above, I haven't seen the error since.
------------------------------------------------------------------------
[2002-08-14 13:41:02] tgannon@colliers-seeley.com
Hello,
I can't come up with a working test case but I have an idea which
might help narrow the search. I have two PHP applications, one of
which works fine in IIS and the other of which causes this bug
frequently. The only significant difference that I can find between
the two apps is that the one that hangs IIS uses sessions and cookies,
whereas the stable one does not.
I removed the calls to session_start and session_register from the
unstable one, and after some testing it appears to still work. I'll
give an update after some more testing has been done.
Windows 2000 Server, Service pack 3 + .NET Framework (sp2)
PHP 4.2.2 as ISAPI
------------------------------------------------------------------------
[2002-07-26 14:10:17] agustinchernitsky@hotmail.com
James,
Win2K
2.00.2195
SP2
IIS 5.0.2195.2966
PHP 4.2.1
Create a Web Site with ISAPI, make the PHP do some lookups in MySQL
(Install PHPMyAdmin). That should do it... No security Service Packs
are Installed, Just SP2.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/15333
--
Edit this bug report at http://bugs.php.net/?id=15333&edit=1