Bug #67445 [NEW]: cannot run PHP-FPM master process by www-data user
| From: | multitor4 at gmail dot com | Date: | Sat, 14 Jun 2014 23:53:49 +0000 |
| Subject: | Bug #67445 [NEW]: cannot run PHP-FPM master process by www-data user | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-186195@lists.php.net to get a copy of this message | ||
From: multitor4 at gmail dot com
Operating system: Debian
PHP version: 5.5.13
Package: FPM related
Bug Type: Bug
Bug description:cannot run PHP-FPM master process by www-data user
Description:
------------
My PHP-FPM configuration works: I could run php-fpm with sudo php-fpm &
command, and with ps aux | grep "php-fpm" I could see one master process
running as root, and two daughter processes running as www-data user:
(output stripped for convenience)
root php-fpm: master process (/usr/local/etc/php-fpm.conf)
www-data php-fpm: pool www
www-data php-fpm: pool www
Webserver works perfectly as well.
BUG:
I heard somewhere that running PHP-FPM as a root could be potentially
not good for security, so I decided to try to launch master process as
www-data user:
su -c "php-fpm &" -s /bin/sh www-data
But, it returns an error:
ERROR: failed to open error_log (/usr/local/var/log/php-fpm.log):
Permission denied (13)
ERROR: failed to post process the configuration
ERROR: FPM initialization failed
I have tried to change permissions of php-fpm.log file and
/usr/local/var/log folder, even to 777, also tried various owners with
chmod command ( my current user, www-data, root, etc ) But, that does
not eliminate an error
--
Edit bug report at https://bugs.php.net/bug.php?id=67445&edit=1
--