Bug #67606 [Com]: FPM with mod_fastcgi/apache2.4 is broken after db537b1f commit

From: Date: Fri, 11 Jul 2014 14:26:15 +0000
Subject: Bug #67606 [Com]: FPM with mod_fastcgi/apache2.4 is broken after db537b1f commit
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-186565@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=67606&edit=1

 ID:                 67606
 Comment by:         dz at heroku dot com
 Reported by:        ondrej@php.net
 Summary:            FPM with mod_fastcgi/apache2.4 is broken after
                     db537b1f commit
 Status:             Open
 Type:               Bug
 Package:            FPM related
 Operating System:   Linux
 PHP Version:        5.6.0RC2
 Block user comment: N
 Private report:     N

 New Comment:

He says he can't use mod_proxy_fcgi, because the Authorization header is stripped by mod_proxy,
but this is documented behavior.

He should simply add

SetEnvIfNoCase ^Authorization$ "(.+)" HTTP_AUTHORIZATION=$1

to his config.

With https://gist.github.com/progandy/6ed4eeea60f6277c3e39
(or Apache 2.4.10+) and 5.6.0RC2+, there are no more issues like double slashes or errors when
rewriting to PATH_INFO (see PR link below).

The "break" in question was caused by https://github.com/php/php-src/pull/694; it
fixes the issue described in https://bugs.php.net/bug.php?id=67541.

It also makes https://bugs.php.net/bug.php?id=65641 obsolete

mod_fastcgi is old, crappy, unmaintained, deprecated stuff. People should use mod_proxy_fcgi with
Apache 2.4.

I'll try and see if I can figure out a way of fixing the original issue without causing the
breakage described here (need to get mod_fastcgi working first, which isn't trivial
unfortunately).


Previous Comments:
------------------------------------------------------------------------
[2014-07-11 07:36:04] ondrej@php.net

Description:
------------
As reported in https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=754384

Reverting db537b1f fixes the issue.

Test script:
---------------
mod_fastcgi configuration:

AddHandler php5-fcgi .php
Action php5-fcgi /php5-fcgi
Alias /php5-fcgi /usr/lib/cgi-bin/php5-fcgi
FastCgiExternalServer /usr/lib/cgi-bin/php5-fcgi -socket /var/run/php5-fpm.sock -pass-header
Authorization


Expected result:
----------------
Page interpreted and loaded.

Actual result:
--------------
After the upgrade, every PHP page displays "file not found" and I get this error in
/var/log/apache2/error.log:

FastCGI: server "/usr/lib/cgi-bin/php5-fcgi" stderr: Primary script unknown


------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=67606&edit=1


Thread (11 messages)

« previous php.bugs (#186565) next »