#4186 [Com]: Undefined symbol _muldi3
| From: | melzer at lfrz dot at | Date: | Mon, 09 Sep 2002 09:15:52 +0000 |
| Subject: | #4186 [Com]: Undefined symbol _muldi3 | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-18730@lists.php.net to get a copy of this message | ||
ID: 4186
Comment by: melzer@lfrz.at
Reported By: tixier@france-loisirs.com
Status: Closed
Bug Type: Installation problem
Operating System: Solaris 2.6
PHP Version: 4.0 Release Candidate 1
New Comment:
I had the same error message under Solaris 7 and 9 when compileing
apache && php with ldap support.
I used the openldap-libraries.
The --enable-libgcc option solved the problem.
Now everything works fine :o)
thanks
Previous Comments:
------------------------------------------------------------------------
[2000-05-15 15:14:05] sas@cvs.php.net
Please configure PHP with --enable-libgcc.
------------------------------------------------------------------------
[2000-04-19 10:15:40] tixier@france-loisirs.com
Can't start Apache:
Syntax error on line 238 of /app/apache/conf/httpd.conf:
Cannot load /app/apache/libexec/libphp4.so into server: ld.so.1:
/app/apache/bin
/httpd: fatal: relocation error: file /app/apache/libexec/libphp4.so:
symbol __muldi3: referenced symbol not found
/app/apache/bin/apachectl start: httpd could not be started
PHP was comfigured with:
./configure \
--with-apxs=/app/apache/bin/apxs \
--disable-debug \
--without-gd
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=4186&edit=1