Bug #67937 [NEW]: Rebooting Apache2.4 again and again caused by php_opcache.dll.
| From: | o6asan at yahoo dot de | Date: | Sat, 30 Aug 2014 11:18:29 +0000 |
| Subject: | Bug #67937 [NEW]: Rebooting Apache2.4 again and again caused by php_opcache.dll. | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-187349@lists.php.net to get a copy of this message | ||
From: o6asan at yahoo dot de
Operating system: Windows7 HP SP1 x86
PHP version: 5.6.0
Package: opcache
Bug Type: Bug
Bug description:Rebooting Apache2.4 again and again caused by php_opcache.dll.
Description:
------------
On August 28 around 09:30, I migrated from PHP5.5.16 to PHP5.6.0.
At first access I had a 'Bad host request' from my site after rebooting
the httpd.exe. At that time I couldn't find why, so I rebooted Windows7
itself and I could run the server and see my site.
Windows7HP+SP1(x86)
httpd-2.4.10-win32-VC11.zip from Apache Lounge
php-5.6.0-Win32-VC11-x86.zip from PHP.net
mariadb-10.0.13-win32.zip from MariaDB.ORG
But after a few hours later, I had a 'Bad host request' again. Then I
found a lot of '-- Restarting's on the apache error log. Though I
couldn't find any other information on it, I saw a lot of errors about
php_opcache.dll on the OS event log, like this:
- EventData
httpd.exe
2.4.10.0
53c79afa
php_opcache.dll
5.6.0.0
53fe2bac
c0000005
00018df2
3b8
01cfc38026be3577
D:\Apache24\bin\httpd.exe
D:\PHP\ext\php_opcache.dll
921bb83b-2f73-11e4-b49a-001185bbaf62
As I couldn't find why, I stop using OPcache feature now.
My php.ini based on the php.ini-production included
php-5.6.0-Win32-VC11-x86.zip and I changed the fallowing lines:
--------
output_buffering = Off
disable_functions ="shell_exec, suexec, passthru, phpinfo"
expose_php = Off
extension_dir = "D:\PHP\ext\"
allow_url_fopen = Off
extension=php_curl.dll
extension=php_gd2.dll
extension=php_mbstring.dll
extension=php_mysqli.dll
extension=php_openssl.dll
zend_extension= "D:\PHP\ext\php_opcache.dll"
date.timezone ="xxxx/xxxx"
sendmail_from = My email address
mysql.allow_persistent = Off
opcache.enable=1
opcache.memory_consumption=128
opcache.interned_strings_buffer=8
opcache.max_accelerated_files=4000
opcache.revalidate_freq=60
opcache.fast_shutdown=1
--------
Does zend_extension require php_mysql.dll? In PHP5.5.16 INI file, I
loaded php_mysql.dll.
I cannot find why this occurred still now. Any suggestions?
--
Edit bug report at https://bugs.php.net/bug.php?id=67937&edit=1
--