Bug #67920 [Opn->Csd]: glibc detected *** /usr/bin/php-cgi: free(): invalid pointer: 0x00007f9b0669bb0

From: Date: Fri, 05 Sep 2014 04:16:04 +0000
Subject: Bug #67920 [Opn->Csd]: glibc detected *** /usr/bin/php-cgi: free(): invalid pointer: 0x00007f9b0669bb0
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-187426@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=67920&edit=1 ID: 67920 Updated by: laruence@php.net Reported by: info at air-diensten dot nl Summary: glibc detected *** /usr/bin/php-cgi: free(): invalid pointer: 0x00007f9b0669bb0 -Status: Open +Status: Closed Type: Bug Package: Scripting Engine problem Operating System: CentOS 6.5 (Final) PHP Version: 5.5.15-1.w6 -Assigned To: +Assigned To: laruence Block user comment: N Private report: N New Comment: The fix for this bug has been committed. Snapshots of the sources are packaged every three hours; this change will be in the next snapshot. You can grab the snapshot at http://snaps.php.net/. For Windows: http://windows.php.net/snapshots/ Thank you for the report, and for helping us make PHP better. Previous Comments: ------------------------------------------------------------------------ [2014-09-05 04:15:47] laruence@php.net yeah, this already be fixed in 671caa625534d77e56599a990e5083f9bc0d0f5f ------------------------------------------------------------------------ [2014-08-29 11:15:55] johannes@php.net Even if loaded two times it should not crash. Underlying issue is that in zend_register_extension() we're not checking whether the Zend Extension was already loaded. Therefore the Zend Extension part is initialized and being shut down two times, second shutdown crashes. The error message comes from the PHP module part being loaded by the Zend Extension. A Zend Extension without PHP module part would create no error but undefined behavior only. ------------------------------------------------------------------------ [2014-08-28 17:13:35] info at air-diensten dot nl tnx for it.. your right how stupid.. is solved :$ ------------------------------------------------------------------------ [2014-08-28 07:16:02] laruence@php.net seems you load zend_opcache twice? "PHP Warning: Module 'Zend OPcache' already loaded in Unknown on line 0" "PHP Warning: Zend OPcache: module registration failed! in Unknown on line 0" could you please make sure you only load it once, then test it again? ------------------------------------------------------------------------ [2014-08-28 04:46:31] info at air-diensten dot nl add correct php version ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=67920 -- Edit this bug report at https://bugs.php.net/bug.php?id=67920&edit=1

« previous php.bugs (#187426) next »