Bug #68084 [Opn->Nab]: Unable to load dynamic library

From: Date: Thu, 25 Sep 2014 18:46:02 +0000
Subject: Bug #68084 [Opn->Nab]: Unable to load dynamic library
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-187702@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=68084&edit=1 ID: 68084 Updated by: ab@php.net Reported by: rainer dot stuelp at outlook dot de Summary: Unable to load dynamic library -Status: Open +Status: Not a bug Type: Bug Package: Dynamic loading Operating System: Windows 8.1 64bit PHP Version: master-Git-2014-09-23 (snap) Block user comment: N Private report: N New Comment: Sorry, but your problem does not imply a bug in PHP itself. For a list of more appropriate places to ask for help using PHP, please visit http://www.php.net/support.php as this bug system is not the appropriate forum for asking support questions. Due to the volume of reports we can not explain in detail here why your report is not a bug. The support channels will be able to provide an explanation for you. Thank you for your interest in PHP. I'm not sure why you mention 5.7 as there is no such branch, furthermore AFAIR ext/interbase isn't ported there yet. You probably mean 7-dev which master is now. This anyway doesn't change the matter as you've got the same with 5.6 x64 and the issue is not far to seek. Seems that you're using the dependency DLL compiled for 32 bit, they obviously can't load into a 64 bit binary. Please obtain the correct dependency DLL and this will fix the issue. Thanks. Previous Comments: ------------------------------------------------------------------------ [2014-09-23 11:44:59] rainer dot stuelp at outlook dot de Description: ------------ I have installed the following software: - Windows 8.1 64 bit - Apache 2.4.10 x64 VC11 - PHP 5.7.0-dev (same error with 5.6.0 VC11 x64) In the php.ini I have activate the interbase extension. I copied the FBCLIENT.dll to my PHP directory (same directory where the php.exe is stored) and added this PHP directory to my PATH setting. From a command box I run php.exe and I got the following output on screen: PHP Warning: PHP Startup: Unable to load dynamic library ´D:\WebServer\php\ext\php_interbase.dll´ - %1 is not a valid win32 application in Unknown on line 0 When I use the same version of Apache and PHP, but both as 32bit application (X86), and the same ini files, it works fine and I can access with a php-file to the firebird database. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=68084&edit=1

« previous php.bugs (#187702) next »