#19314 [Opn->Fbk]: unable to startup Apache (undefined symbol)

From: Date: Mon, 09 Sep 2002 13:12:24 +0000
Subject: #19314 [Opn->Fbk]: unable to startup Apache (undefined symbol)
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-18779@lists.php.net to get a copy of this message
ID: 19314 Updated by: sniper@php.net Reported By: pitrou@free.fr -Status: Open +Status: Feedback Bug Type: Apache related Operating System: Linux 2.4.19 PHP Version: 4.2.3 New Comment: You propably don't have /usr/local/lib in /etc/ld.so.conf ? If not, add it and run /sbin/ldconfig and it should all be okay then.. Previous Comments: ------------------------------------------------------------------------ [2002-09-09 08:05:31] pitrou@free.fr Hello, I've tried to upgrade from 4.0.6 to 4.2.3, both versions compiled from source. Although I've used the same options for 4.2.3 as for 4.0.6, when I try to restart Apache I have an error message. It seems it doesn't link to the needed extension libs. # apachectl configtest Syntax error on line 182 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: gdImagePngCtx Here is the configure command : ./configure --with-apxs \ --with-mysql=/usr/local \ --with-bz2 \ --with-zlib \ --with-gd \ If I remove --with-gd, I have a similar error message : # apachectl configtest Syntax error on line 182 of /usr/local/apache/conf/httpd.conf: Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: undefined symbol: uncompress So it is not a problem with GD but rather with the way PHP loads extensions. Is there anything I overlooked in the build/configuration process ? Or is it really a bug ? ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=19314&edit=1

« previous php.bugs (#18779) next »