Bug #68500 [NEW]: Install is not taking into account dependency order in php.ini 'extension'
| From: | yisroel at journeymanweb dot com | Date: | Tue, 25 Nov 2014 20:31:53 +0000 |
| Subject: | Bug #68500 [NEW]: Install is not taking into account dependency order in php.ini 'extension' | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-188790@lists.php.net to get a copy of this message | ||
From: yisroel at journeymanweb dot com
Operating system:
PHP version: 5.4.35
Package: CGI/CLI related
Bug Type: Bug
Bug description:Install is not taking into account dependency order in php.ini 'extension'
Description:
------------
I installed pecl_http
Executing a PHP page yielded an error_log file with:
PHP Warning: PHP Startup: Unable to load dynamic library
'/usr/local/lib/php/extensions/no-debug-non-zts-20100525/http.so' -
/usr/local/lib/php/extensions/no-debug-non-zts-20100525/http.so:
undefined symbol: php_persistent_handle_abandon in Unknown on line 0
This helped: http://stackoverflow.com/a/22429148
PECL installer does not enter the 'extension' entries into php.ini in
the right order. Manually placing http.so after the others fixed the
issue.
Expected result:
----------------
PECL installer should enter the 'extension' entries into php.ini in the
right order.
--
Edit bug report at https://bugs.php.net/bug.php?id=68500&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=68500&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=68500&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=68500&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=68500&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=68500&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=68500&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=68500&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=68500&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=68500&r=support
Expected behavior: https://bugs.php.net/fix.php?id=68500&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=68500&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=68500&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=68500&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=68500&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=68500&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=68500&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=68500&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=68500&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=68500&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=68500&r=mysqlcfg