#19304 [Fbk->Opn]: OCISessionBegin: ORA-03120: two-task conversion routine: integer overflow
ID: 19304
User updated by: pinned@spic.ru
Reported By: pinned@spic.ru
-Status: Feedback
+Status: Open
Bug Type: OCI8 related
Operating System: Solaris 7 x86
PHP Version: 4.2.3
New Comment:
Yes, I am completely sure that ORACLE_HOME, TNS_ADMIN and NLS_LANG are
set before apache started (these variables are also set when I run php
from command line).
If variables aren't set I got ora-12154 (can not resolve service name).
Previous Comments:
------------------------------------------------------------------------
[2002-09-10 01:36:03] thies@php.net
are you _sure_ that all oracle env-vars are setup _before_
your apache process starts (eg in the /etc/init.d/httpd
script)?
------------------------------------------------------------------------
[2002-09-09 23:53:24] pinned@spic.ru
Yes, sqlplus works fine.
------------------------------------------------------------------------
[2002-09-09 06:21:38] thies@php.net
can you connect via sqlplus?
------------------------------------------------------------------------
[2002-09-09 04:48:37] pinned@spic.ru
ora 3120 occurs while attemting to connect to oracle database.
connection to oracle 8.1.7 running on intel - works fine.
error occurs only when connecting to database running on Solaris SPARC
apache version 1.3.26, but error also occurs when running php from
command line.
configure options:
./configure' '--with-apxs=/www/bin/apxs'
'--with-oci8=/u01/app/oracle/product/8.1.7/' '--enable-track-vars'
'--with-mod_charset' '--with-gd=../gd1.3/' '--with-mcrypt'
'--without-mysql'
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=19304&edit=1
Thread (10 messages)