Bug #68378 [Fbk->NoF]: Cannot load pgsql extension
| From: | ab@php.net | Date: | Tue, 23 Dec 2014 19:09:36 +0000 |
| Subject: | Bug #68378 [Fbk->NoF]: Cannot load pgsql extension | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-189164@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=68378&edit=1
ID: 68378
Updated by: ab@php.net
Reported by: tony at marston-home dot demon dot co dot uk
Summary: Cannot load pgsql extension
-Status: Feedback
+Status: No Feedback
Type: Bug
Package: PostgreSQL related
Operating System: Windows
PHP Version: 5.6.2
Block user comment: N
Private report: N
New Comment:
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Re-Opened". Thank you.
Previous Comments:
------------------------------------------------------------------------
[2014-11-09 00:32:19] requinix@php.net
You sure you're editing the right php.ini? Use phpinfo() to check which file you should be
editing.
------------------------------------------------------------------------
[2014-11-08 18:30:12] tony at marston-home dot demon dot co dot uk
Description:
------------
I am running Windows 7 with Apache 2.4.10 and PostgresSQL version 9.2.5. After upgrading my PHP
version from 5.5.18 to 5.6.2 I can longer use the pgsql extension as my code fails with " Call
to undefined function pg_connect()". When I run phpinfo() it shows that the pgsql extension is
not loaded.
When I look in the Apache error log it shows no errors. When I look in the Windows event viewer it
also shows no errors.
This was working perfectly with PHP 5.5.18, so why should a simple upgrade to 5.6.2 cause such a
problem?
Expected result:
----------------
I expect the pgsql extension to be loaded and usable.
Actual result:
--------------
The pgsql extension is not loaded, and there are no error messages explaining why.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=68378&edit=1