Bug #68645 [NEW]: Cannot load oci8 extension
| From: | tony at marston-home dot demon dot co dot uk | Date: | Wed, 24 Dec 2014 10:06:13 +0000 |
| Subject: | Bug #68645 [NEW]: Cannot load oci8 extension | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-189176@lists.php.net to get a copy of this message | ||
From: tony at marston-home dot demon dot co dot uk
Operating system: Windows 7
PHP version: 5.6.4
Package: OCI8 related
Bug Type: Bug
Bug description:Cannot load oci8 extension
Description:
------------
I tried to re-open bug #68379 but it wouldn't let me. The error message
said "â¢You aren't allowed to change a bug to that state.".
I am running Windows 7 with Apache 2.4.10 and Oracle 11g. After
upgrading my PHP version from 5.5.18 to 5.6.4 I can longer use the oci8
extension as my code fails with "Call to undefined function
oci_connect()". When I run phpinfo() it shows that the oci8 extension is
not loaded.
When I look in the Apache error log it shows no errors. When I look in
the Windows event viewer it also shows no errors.
This was working perfectly with PHP 5.5.18, so why should a simple
upgrade to 5.6.4 cause such a problem?
I did not edit my php.ini file as I was using exactly the same settings
as before. All I did was replace the PHP 5.5.18 code with that for 5.6.4
and this extension failed to work as I expected.
Expected result:
----------------
I expect the oci8 extension to be loaded and usable.
Actual result:
--------------
The oci8 extension is not loaded, and there are no error messages
explaining why.
--
Edit bug report at https://bugs.php.net/bug.php?id=68645&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=68645&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=68645&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=68645&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=68645&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=68645&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=68645&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=68645&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=68645&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=68645&r=support
Expected behavior: https://bugs.php.net/fix.php?id=68645&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=68645&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=68645&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=68645&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=68645&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=68645&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=68645&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=68645&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=68645&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=68645&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=68645&r=mysqlcfg