Bug #68646 [Opn->Fbk]: Cannot load pgsql extension

From: Date: Wed, 24 Dec 2014 17:29:37 +0000
Subject: Bug #68646 [Opn->Fbk]: Cannot load pgsql extension
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-189183@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=68646&edit=1 ID: 68646 Updated by: ab@php.net Reported by: tony at marston-home dot demon dot co dot uk Summary: Cannot load pgsql extension -Status: Open +Status: Feedback Type: Bug Package: PostgreSQL related Operating System: Windows 7 PHP Version: 5.6.4 Block user comment: N Private report: N New Comment: Ok, so this is checked. Please do the following cd <5.6 folder path> php -n -d extension_dir=ext -d extension=php_pgsql.dll -m do you see the pgsql ext loading? Thanks. Previous Comments: ------------------------------------------------------------------------ [2014-12-24 15:12:54] tony at marston-home dot demon dot co dot uk No, I did not edit the wrong php.ini file. I did not edit any file at all as I already had a working PHP installation. All I did was overwrite my 5.5.18 installation with the files for 5.6.4, and the pgsql extension simply stopped working. ------------------------------------------------------------------------ [2014-12-24 13:00:30] ab@php.net @tony at marston-home dot demon dot co dot uk, it doesn't really help to open a new ticket if you gave no feedback in the previous one. Please check what requinix was asking you there, then lets see further. Thanks. ------------------------------------------------------------------------ [2014-12-24 10:12:10] tony at marston-home dot demon dot co dot uk Description: ------------ I tried to re-open bug #68378 but it wouldn't let me. The error message said "You aren't allowed to change a bug to that state.". I am running Windows 7 with Apache 2.4.10 and Oracle 11g. After upgrading my PHP version from 5.5.18 to 5.6.4 I can longer use the pgsqlextension as my code fails with "Call to undefined function pg_connect()". When I run phpinfo() it shows that the pgsql extension is not loaded. When I look in the Apache error log it shows no errors. When I look in the Windows event viewer it also shows no errors. This was working perfectly with PHP 5.5.18, so why should a simple upgrade to 5.6.4 cause such a problem? I did not edit my php.ini file as I was using exactly the same settings as before. All I did was replace the PHP 5.5.18 code with that for 5.6.4 and this extension failed to work as I expected. Expected result: ---------------- I expect the pgsql extension to be loaded and usable. Actual result: -------------- The pgsql extension is not loaded, and there are no error messages explaining why. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=68646&edit=1

« previous php.bugs (#189183) next »