Req #29063 [Opn]: no error is logged if php error_log could not be opened
| From: | ajf@php.net | Date: | Thu, 08 Jan 2015 23:06:09 +0000 |
| Subject: | Req #29063 [Opn]: no error is logged if php error_log could not be opened | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-189771@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=29063&edit=1
ID: 29063
Updated by: ajf@php.net
Reported by: akorthaus at web dot de
Summary: no error is logged if php error_log could not be
opened
Status: Open
Type: Feature/Change Request
-Package: Feature/Change Request
+Package: *General Issues
-Operating System: Linux 2.4.26
+Operating System: Irrelevant
-PHP Version: 4.3.7
+PHP Version: *
Block user comment: N
Private report: N
New Comment:
Not sure if this is still broken, but I'll bump the version anyway.
Previous Comments:
------------------------------------------------------------------------
[2004-07-08 12:58:01] akorthaus at web dot de
Description:
------------
I have the following settings in php.in + phpinfo():
log_errors = On
error_log = "/var/log/apache/php_error.log"
Server API: Apache (mod_php)
Apache-Version: 1.3.31
But if I produce a php-error, this error gets logged into Apache error-log:
/var/log/apache/error_log, and not into /var/log/apache/php_error.log, as configured.
The reason was that mod_php not like mod_gzip and mod_ssl, loggs errors with rights of the apache
child-process.
The Apache user cannot create files in /var/log/apache, and cannot write to files owned by root.
But there is no error-message in Apaches error_log, I would expect something like "could not
open '/var/log/apache/php_error.log', permission denied". Only php-errors itself get
logged into Apaches error_log.
perhaps its a "feature request".
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=29063&edit=1