Bug #69075 [Fbk->Csd]: Entry Point Not Found Error
Edit report at https://bugs.php.net/bug.php?id=69075&edit=1
ID: 69075
User updated by: jfha73 at gmail dot com
Reported by: jfha73 at gmail dot com
Summary: Entry Point Not Found Error
-Status: Feedback
+Status: Closed
Type: Bug
Package: Apache2 related
Operating System: Windows
PHP Version: master-Git-2015-02-18 (Git)
Block user comment: N
Private report: N
New Comment:
Found the problem, the key word is "extension" I forgot that I always compiled my own with
OCI support which was working before, but now that is not compiling OCI, the old one in place was
causing this problem, once I took it off my php.ini it started working again.
Thanks again.
Previous Comments:
------------------------------------------------------------------------
[2015-02-20 09:25:13] ab@php.net
To clear this out, you can use procmon from sysinternals https://technet.microsoft.com/en-us/sysinternals/bb896645.aspx
to check from where a DLL was loaded.
What also comes in my mind - are you using some non core extensions there? It's currently
unclear, what requires those symbols. But the core should be all good.
Cheers
------------------------------------------------------------------------
[2015-02-19 19:36:48] jfha73 at gmail dot com
I only have 1 php7ts.dll and that's the one at D:\PHP7, the folder has never been in my %PATH%
before and it has always worked, I'll try adding it, but what could have caused it? D:\PHP7 has
never been in my path and it has worked every time, only this past few days it has stopped working.
Thanks Anatol.
------------------------------------------------------------------------
[2015-02-19 18:37:37] ab@php.net
Yeah, but please keep in mind, that it blames about php7ts.dll and Apache will do chroot. So on the
console, before starting Apache, one should do
set path=D:\php7;%path%
Also, no other php7ts.dll should be in the Apache root. Or if Apache runs as a service, the path to
php7 dir should precede anything else about PHP. Could you please try that?
Thanks.
------------------------------------------------------------------------
[2015-02-19 14:26:03] jfha73 at gmail dot com
My line in httpd.conf is:
LoadModule php7_module "D:/php7/php7apache2_4.dll"
Also, it won't show you when starting Apache, it will just fail to start, it will show if you
run a
httpd -k status
------------------------------------------------------------------------
[2015-02-19 13:47:54] ab@php.net
Hi Jorge,
I cannot reproduce this. I just could guess that it's a dll hell issue. You probably should
check which dll is indeed being loaded.
Cheers.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=69075
--
Edit this bug report at https://bugs.php.net/bug.php?id=69075&edit=1
Thread (7 messages)