Edit report at https://bugs.php.net/bug.php?id=45786&edit=1
ID: 45786
Comment by: a dot gegg at btinternet dot com
Reported by: karelevzen at gmail dot com
Summary: FastCGI process exited unexpectedly
Status: Closed
Type: Bug
Package: CGI/CLI related
Operating System: Windows Vista Ultimate x64 SP1
PHP Version: 5.3CVS-2008-08-10 (CVS)
Assigned To: dmitry
Block user comment: N
Private report: N
New Comment:
I have just had this problem, suddenly, after several days happily using PHP and IIS 7 on Win7.
Following [sejo at iteontech dot com]'s advice I double clicked php-cgi.exe and it reported
php5.dll was missing! I copied it back, ran a test script and Norton anti-virus popped up declaring
php5.dll a threat to civilization as we know it and that it had removed php5.dll. I ignored the AV
advice that php5 would end the known universe and over-rode the removal.
So far, the skies have not turned black and no bottomless pit has opened around me...
Previous Comments:
------------------------------------------------------------------------
[2010-04-22 06:43:42] sejo at iteontech dot com
After debugging IIS and a bunch of other crazy things, this is what worked for me. I have PHP 5.3.2
on Windows 7 and IIS 7.
Try to execute PHP-CGI.EXE (BY DOUBLECLICKING ON IT). See if you get any error messages/ pop-ups. I
got a ton of them and it all boiled down on having a bunch of extensions turned on, but not being
available in my ext folder. Clear the PHP.INI of those invalid extensions and the problem should go
away.
------------------------------------------------------------------------
[2010-04-12 19:36:05] pajoye@php.net
Did you enable mbstring as well? And put it before exif in the list? Exif requires mbstring.
However that's unrelated to this bug, please ask for support on the PHP windows mailing list
(or any other support channel).
------------------------------------------------------------------------
[2010-04-12 19:11:02] differentpk at gmail dot com
I had the same problem like error 500, I set all extentions off and the problem was gone. Then i
uncommented extentions one by one and found that the problems occures at ;extension=php_exif.dll.
Though i removed the error message but i am still unable to find the solution yet.
------------------------------------------------------------------------
[2008-08-26 09:59:12] dmitry@php.net
This bug has been fixed in CVS.
Snapshots of the sources are packaged every three hours; this change
will be in the next snapshot. You can grab the snapshot at
http://snaps.php.net/.
Thank you for the report, and for helping us make PHP better.
------------------------------------------------------------------------
[2008-08-18 18:45:10] karelevzen at gmail dot com
If this helps, I have created a dump 6 seconds after executing the page.
Thread 0:
ntdll!NtDelayExecution+15
kernel32!SleepEx+62
kernel32!Sleep+f
php5ts!php_get_inf+1eaf
php5ts!execute+cc5
php5ts!execute+6130
Thread 1:
user32!NtUserGetMessage+15
user32!GetMessageA+a2
php5ts!zend_timeout+1a8
Another thing I found interesting is, that upon the request, a php-cgi.exe is created and does
nothing. After the timeout, in the same exact moment, a new php-cgi.exe is created, the old
php-cgi.exe is destroyed and the page is rendered. Is this behaviour normal or should I futher
investigate this strange process?
This second php-cgi.exe process is destroyed upon refresh and the display of the IIS error message.
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=45786
--
Edit this bug report at https://bugs.php.net/bug.php?id=45786&edit=1