Bug #55777 [Opn->Nab]: Error starting Apache server

From: Date: Thu, 28 May 2015 12:40:22 +0000
Subject: Bug #55777 [Opn->Nab]: Error starting Apache server
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-192967@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=55777&edit=1 ID: 55777 Updated by: cmb@php.net Reported by: jlmueller at optonline dot net Summary: Error starting Apache server -Status: Open +Status: Not a bug Type: Bug Package: Apache2 related Operating System: win xp sp3 PHP Version: 5.3.8 -Assigned To: +Assigned To: cmb Block user comment: N Private report: N New Comment: Sorry, but your problem does not imply a bug in PHP itself. For a list of more appropriate places to ask for help using PHP, please visit http://www.php.net/support.php as this bug system is not the appropriate forum for asking support questions. Due to the volume of reports we can not explain in detail here why your report is not a bug. The support channels will be able to provide an explanation for you. Thank you for your interest in PHP. Quite likely the problem has been caused by a missing or incompatible DLL. Recent downloads of PHP binaries contain deplister.exe (otherwise you can get it from <http://windows.php.net/downloads/pecl/tools/>), which can be used to check the dependencies of a certain binary (PE module). Previous Comments: ------------------------------------------------------------------------ [2011-12-08 16:26:40] justin dot mcdaniel at shipconstructor dot com I was able to solve the issue by commenting out the PHP_SQLSRV extension. If you are not hooking up to an MSSQL database, please find the [PHP_SQLSRV] extension line and comment it out: Change: [PHP_SQLSRV] extension=php_sqlsrv.dll To this: ; [PHP_SQLSRV] ; extension=php_sqlsrv.dll If you do need this extension, then you might want to try finding another version of the dll as the one included with PHP 5.3.8 appears to cause errors. ------------------------------------------------------------------------ [2011-10-20 01:04:21] jlmueller at optonline dot net I tried going back to PHP 5.2.17 and now things work normally. I guess there is problem with the 5.3.x version form my configuration ------------------------------------------------------------------------ [2011-10-08 01:20:15] jlmueller at optonline dot net I tried haryo's suggested change of '/' instead of '\'. I still get the same error message as before. ------------------------------------------------------------------------ [2011-10-07 04:15:39] haryo at ukdw dot ac dot id i've got same error with apache 2.2.21 and php 5.3.8 on windows 2008 server, then i try to change '\' character with '/' and apache run smoothly here's my conf PHPIniDir "C:/PHP/" LoadFile "C:/PHP/php5ts.dll" LoadModule php5_module "C:/PHP/php5apache2_2.dll" php_value extension_dir "C:/PHP/ext/" funny thing is: i have apache 2.2.19 which running okay with '\' char ..sorry for my english, it's not my first language ------------------------------------------------------------------------ [2011-09-25 01:34:02] jlmueller at optonline dot net Description: ------------ Just installed Apache 2.2.21 upgrade and PHP 5.3.8. Had run earlier editions of both without problem. We starting the Apache server it fails with the following error Faulting application httpd.exe, version 2.2.21.0, faulting module php5ts.dll, version 5.3.8.0, fault address 0x000f8a90. It is repeatable. If I comment out the following PHP entries in the Apache hppd.config file entries PHPIniDir "C:\Program Files\PHP\" LoadModule php5_module "C:\Program Files\PHP\php5apache2_2.dll" Apache will start and I can do non-PHP based pages ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=55777&edit=1

« previous php.bugs (#192967) next »