Req #68359 [Com]: Apache 2.4 Can't locate API module structure `php5_module' in libphp5.so
Edit report at https://bugs.php.net/bug.php?id=68359&edit=1
ID: 68359
Comment by: vz at shsa dot ru
Reported by: ebrahim at imami dot net
Summary: Apache 2.4 Can't locate API module structure
`php5_module' in libphp5.so
Status: Open
Type: Feature/Change Request
Package: Apache related
Operating System: CentOS 6.5
PHP Version: 5.6.2
Block user comment: N
Private report: N
New Comment:
I've installed php
php -v
PHP 5.6.9 (cli) (built: Jun 4 2015 18:53:50)
Copyright (c) 1997-2015 The PHP Group
Zend Engine v2.6.0, Copyright (c) 1998-2015 Zend Technologies
uname -a
FreeBSD some.domain 8.4-STABLE FreeBSD 8.4-STABLE
in the httpd.conf there is
LoadModule php5_module /usr/local/lib/libphp5.so
When I try to apachectl start
Performing sanity check on apache22 configuration:
httpd: Syntax error on line 107 of /usr/local/etc/apache22/httpd.conf: Can't locate API module
structure `php5_module' in file /usr/local/lib/libphp5.so: Undefined symbol
"php5_module"
Starting apache22.
httpd: Syntax error on line 107 of /usr/local/etc/apache22/httpd.conf: Can't locate API module
structure `php5_module' in file /usr/local/lib/libphp5.so: Undefined symbol
"php5_module"
/usr/local/etc/rc.d/apache22: WARNING: failed to start apache22
What to do?
Previous Comments:
------------------------------------------------------------------------
[2014-11-06 02:36:27] ebrahim at imami dot net
Description:
------------
I have installed Apache 2.4.10 on CentOS 6.5
and also PHP 5.6.2
when I add LoadModule /usr/lib/libphp5.so in httpd.conf
and restart service , I get following error:
... /etc/httpd/conf/httpd.conf: Can't locate API module structure `php5_module' in file
/usr/lib/libphp5.so: /usr/lib/libphp5.so: undefined symbol: php5_module
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=68359&edit=1
Thread (3 messages)