#10871 [Fbk->NoF]: pclose() failed. (2: unknown early startup error)

From: Date: Sat, 14 Sep 2002 06:00:01 +0000
Subject: #10871 [Fbk->NoF]: pclose() failed. (2: unknown early startup error)
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-19331@lists.php.net to get a copy of this message
ID: 10871 Updated by: php-bugs@lists.php.net Reported By: mh@fluxus.net -Status: Feedback +Status: No Feedback Bug Type: iPlanet related Operating System: Solaris 2.6 PHP Version: 4.0.5 New Comment: No feedback was provided for this bug for over a month, so it is being suspended automatically. If you are able to provide the information that was originally requested, please do so and change the status of the bug back to "Open". Previous Comments: ------------------------------------------------------------------------ [2002-08-13 22:49:12] iliaa@php.net Thank you for taking the time to report a problem with PHP. Unfortunately you are not using a current version of PHP -- the problem might already be fixed. Please download a new PHP version from http://www.php.net/downloads.php If you are able to reproduce the bug with one of the latest versions of PHP, please change the PHP version on this bug report to the version you tested and change the status back to "Open". Again, thank you for your continued support of PHP. ------------------------------------------------------------------------ [2001-05-15 09:11:18] mh@fluxus.net No problem with 4.0.4pl1... ------------------------------------------------------------------------ [2001-05-15 05:14:59] mh@fluxus.net When I start the web server, I have a "[https-test]: pclose() failed. (2: unknown early startup error)" message I installed php 4.0.5 with Oracle 8.1.6 support and Netscape Enterprise 3.6SP3 with : ./configure --without-mysql --with-nsapi=/opt/netscape/suitespot --with-oci8=/opt/oracle/816 make ; make install First, I had more error messages : [https-test]: pclose() failed. (2: unknown early startup error) [https-test]: conf_init: Error running init function load-modules: dlopen of /opt/netscape/suitespot/bin/libphp4.so failed (ld.so.1: ns-httpd: fatal: libstdc++.so.2.8.1.1: open failed: No such file or directory) So I added the path for libstdc++ in LD_LIBRARY_PATH in the start file. Then, I had this : [https-test]: pclose() failed. (2: unknown early startup error) [https-test]: conf_init: Error running init function load-modules: dlopen of /opt/netscape/suitespot/bin/libphp4.so failed (ld.so.1: ns-httpd: fatal: libclntsh.so.8.0: open failed: No such file or directory) So I also added Oracle lib path in the start file. Now I just have the first line, and no other error message. The Web Server just won't start. my obj.conf is : # Netscape Communications Corporation - obj.conf # You can edit this file, but comments and formatting changes # might be lost when the admin server makes changes. Init fn="flex-init" access="/opt/netscape/suitespot/https-test/logs/access" form at.access="%Ses->client.ip% - %Req->vars.auth-user% [%SYSDATE%] \"%Req->reqpb.cl f-request%\" %Req->srvhdrs.clf-status% %Req->srvhdrs.content-length%" Init fn="load-types" mime-types="mime.types" Init fn="load-modules" funcs="php4_init,php4_close,php4_execute,php4_auth_trans" shlib="/opt/netscape/suitespot/bin/libphp4.so" Init fn=php4_init errorString="Failed to initialize PHP!" <Object name="default"> NameTrans fn="pfx2dir" from="/ns-icons" dir="/opt/netscape/suitespot/ns-icons" NameTrans fn="pfx2dir" from="/mc-icons" dir="/opt/netscape/suitespot/ns-icons" NameTrans fn="pfx2dir" from="/help" dir="/opt/netscape/suitespot/manual/https/ug" NameTrans fn="document-root" root="/www/test/htdocs" PathCheck fn="unix-uri-clean" PathCheck fn="check-acl" acl="default" PathCheck fn="find-pathinfo" PathCheck fn="find-index" index-names="index.html,home.html" ObjectType fn="type-by-extension" ObjectType fn="force-type" type="text/plain" Service fn="php4_execute" type="magnus-internal/x-httpd-php" Service method="(GET|HEAD)" type="magnus-internal/imagemap" fn="imagemap" Service method="(GET|HEAD)" type="magnus-internal/directory" fn="index-common" Service method="(GET|HEAD)" type="*~magnus-internal/*" fn="send-file" AddLog fn="flex-log" name="access" </Object> <Object name="cgi"> ObjectType fn="force-type" type="magnus-internal/cgi" Service fn="send-cgi" </Object> <Object name="x-httpd-php"> ObjectType fn="force-type" type="magnus-internal/x-httpd-php" Service fn=php4_execute </Object> Any idea ? ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=10871&edit=1

« previous php.bugs (#19331) next »