Bug #70212 [Com]: sapi/cli/php: object requires TLS, but TLS failed to initialize

From: Date: Sat, 15 Aug 2015 12:33:12 +0000
Subject: Bug #70212 [Com]: sapi/cli/php: object requires TLS, but TLS failed to initialize
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-195228@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=70212&edit=1

 ID:                 70212
 Comment by:         truniger at bluewin dot ch
 Reported by:        truniger at bluewin dot ch
 Summary:            sapi/cli/php: object requires TLS, but TLS failed to
                     initialize
 Status:             Open
 Type:               Bug
 Package:            Compile Failure
 Operating System:   Solaris
 PHP Version:        5.5.28
 Block user comment: N
 Private report:     N

 New Comment:

The problem is caused by the patch of #70002 to main/php_open_temporary_file.c. Reverting this patch
removes the problem for both 5.5.28 and 5.6.12.

Compilation of the source does not throw an error but all the binaries are broken. The resulting
error message "object requires TLS, but TLS failed to initialize" is thrown when running
the broken php binary to create phar. I guess the problem is not really related to TLS.

So I guess patch of #70002 needs an update for Solaris but I have no clue about it.


Previous Comments:
------------------------------------------------------------------------
[2015-08-08 08:30:47] truniger at bluewin dot ch

Description:
------------
compiling 5.5.28 and 5.6.12 fails resulting in this error line:
sapi/cli/php: object requires TLS, but TLS failed to initialize

this happens with the exact same environment and configure options as with 5.5.27 and 5.6.11 where
there was no such problem.

I assume a common change in both 5.5 and 5.6 tree causes my problem. But I have no clue what to look
for. 

I tried with reverting patch for ext/openssl/openssl.c but this doesn't make a difference.

I'm using some older gcc and GNU ld on Solaris. I guess that's a little exotic but if it
worked for 5.5.27 which is in production it should work also for 5.5.28. Please help so I can use
the security fixes.



------------------------------------------------------------------------



--
Edit this bug report at https://bugs.php.net/bug.php?id=70212&edit=1


Thread (5 messages)

« previous php.bugs (#195228) next »