Bug #70423 [Com]: Warning Internal error: wrong size calculation

From: Date: Mon, 07 Sep 2015 13:35:17 +0000
Subject: Bug #70423 [Com]: Warning Internal error: wrong size calculation
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-195848@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=70423&edit=1 ID: 70423 Comment by: ck+php dot net at bbshowcase dot org Reported by: ck+php dot net at bbshowcase dot org Summary: Warning Internal error: wrong size calculation Status: Feedback Type: Bug Package: opcache Operating System: CentOS 7.1 PHP Version: master-Git-2015-09-03 (Git) Block user comment: N Private report: N New Comment: @ab - Appears to have solved the problem, no more warnings. Many thanks. Previous Comments: ------------------------------------------------------------------------ [2015-09-07 13:06:33] ab@php.net @"ck+php dot net" #69838 is similar, but this one looks like have been caused by some change after it. Please check now. Thanks. ------------------------------------------------------------------------ [2015-09-07 13:04:13] ab@php.net @tm8544 please check the latest master. Thanks. ------------------------------------------------------------------------ [2015-09-07 13:03:19] ab@php.net Automatic comment on behalf of ab Revision: http://git.php.net/?p=php-src.git;a=commit;h=eaf96698c7e3229b0217ca3a408fb3b50b9bd333 Log: Fix bug #70423 Warning Internal error: wrong size calculation ------------------------------------------------------------------------ [2015-09-07 12:59:31] tm8544 at hotmail dot com I also see this bug with 7.0.0RC2 x64 TS + Apache/2.4.16 x64 on Windows 10 x64 Error message is shown only on some certain PHP scripts, not all of them. Here is a part of Apache log: Sun Sep 6 11:28:12 2015 (5668): Warning Internal error: wrong size calculation: D:\HTTPS-SERVER\mysqladm1n007\libraries\user_preferences.lib.php start=0x20775678, end=0x2077d288, real=0x2077d268 Sun Sep 6 11:28:21 2015 (5656): Warning Internal error: wrong size calculation: D:\HTTPS-SERVER\mysqladm1n007\libraries\transformations.lib.php start=0x208c1758, end=0x208cbff0, real=0x208cbfd0 Mon Sep 7 15:50:44 2015 (4904): Warning Internal error: wrong size calculation: D:\HTTPS-SERVER\mysqladm1n007\libraries\user_preferences.lib.php start=0x20755448, end=0x2075d058, real=0x2075d038 ------------------------------------------------------------------------ [2015-09-04 10:55:50] ck+php dot net at bbshowcase dot org I should also note, the error only happens ONCE upon php-fpm restart, perhaps when those two scripts are put into the cache the first time? If I restart php-fpm I can consistently reproduce the error. The start/end/real numbers change of course. Maybe somewhat relevant it is in an openvz vps container but in theory that should not affect php? Happy to test any patch you'd like to try. ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at https://bugs.php.net/bug.php?id=70423 -- Edit this bug report at https://bugs.php.net/bug.php?id=70423&edit=1

« previous php.bugs (#195848) next »