Bug #70197 [Com]: Changing php file will give blank page

From: Date: Tue, 20 Oct 2015 22:56:06 +0000
Subject: Bug #70197 [Com]: Changing php file will give blank page
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-196715@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=70197&edit=1

 ID:                 70197
 Comment by:         contact at sleeklane dot com
 Reported by:        venancio1981 at gmail dot com
 Summary:            Changing php file will give blank page
 Status:             Open
 Type:               Bug
 Package:            opcache
 Operating System:   Centos 6.6
 PHP Version:        7.0.0beta2
 Block user comment: N
 Private report:     N

 New Comment:

I'm also seeing this on RC4.

But I do not need to edit a file to get the blank page on Invision Power Suit 4, All I need to do is
enable opcache then refresh the page a couple times and I get a blank page no error's nothing
in the logs. once I have the blank page after a couple more refreshes it comes back but then goes
blank again after more refreshes of the page.


Previous Comments:
------------------------------------------------------------------------
[2015-10-06 13:19:12] venancio1981 at gmail dot com

Im having this bug again in RC4.
There was some kind of regression?

------------------------------------------------------------------------
[2015-09-09 15:08:56] venancio1981 at gmail dot com

Yes, it seems fixed in RC2

------------------------------------------------------------------------
[2015-09-09 15:03:01] mihor dot cz at gmail dot com

It seems like it's fixed in PHP 7 RC2.
Can somebody please check it as well?

Thank you

------------------------------------------------------------------------
[2015-08-27 04:27:37] mihor dot cz at gmail dot com

*changing php files (not chaning php files - sorry for that typo)

I forgot to mention three things:

1) Scenario 2 always! caused fatal error

2) Same as venancio1981 - after fatal error I have to restart apache service to solve the problem
(temporarily till next change)

3) Same as venancio1981 - PHP 5.6.12 with opcache enabled is working fine

------------------------------------------------------------------------
[2015-08-26 19:53:07] mihor dot cz at gmail dot com

Hello PHP team!

I experienced this bug(?) too!

I just repeatedly experienced (on my demand - with testing) that it's caused by opcache with
combination of chaning php files (in my case with # svn up command)

Scenario 1: (disabled opcache) - tested multiple times
upping PHP code with svn (up and down to specific revision)
Everything is working fine every time.

Scenario 2: (enabled opcache) - tested multiple times
upping PHP code with svn (up and down to specific revision) or chaning it via Sublime+ExpanDrive
connected to Linux server via SSH

I repeatedly uninstalled opcache and tested (scenario 1) and then installed opcache and tested
(scenario 2) and then again uninstalled, installed etc etc and every time same result.

Error is like this:
Fatal error: Class 'MyClass' not found in
/var/www/html/project/classes/MyClassExtension.php on line 8

System: CentOS 6
PHP version: 7.0.0RC1

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=70197


--
Edit this bug report at https://bugs.php.net/bug.php?id=70197&edit=1


Thread (17 messages)

« previous php.bugs (#196715) next »