Bug #70945 [NEW]: php-fpm don't start : ERROR: no data have been read from pipe failed

From: Date: Fri, 20 Nov 2015 08:44:53 +0000
Subject: Bug #70945 [NEW]: php-fpm don't start : ERROR: no data have been read from pipe failed
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-197345@lists.php.net to get a copy of this message
From: vincent at lws-hosting dot com Operating system: Debian 7 PHP version: 7.0.0RC7 Package: FPM related Bug Type: Bug Bug description:php-fpm don't start : ERROR: no data have been read from pipe failed Description: ------------ We install php 7 on our servers to test and prepare for its release. However, on some of our servers, php 7 will not start with this error: # Php7.0-fpm service start Starting php-fpm [20-Nov-2015 8:34:32] ERROR: no data-have been read from pipe failed All servers are identical, running on openvz and multiple php-fpm (5.4, 5.5 and 5.6). We can get the same error when trying to restart php-fpm while a proceeding is already underway. Configure line : ./configure --prefix=/opt/php${pv} --with-pdo-pgsql --with-zlib-dir --with-freetype-dir --enable-mbstring --with-libxml-dir=/usr --enable-soap --enable-calendar --with-curl --with-mcrypt --with-zlib --with-gd --with-pgsql --disable-rpath --enable-inline-optimization --with-bz2 --with-zlib --enable-sockets --enable-sysvsem --enable-sysvshm --enable-pcntl --enable-mbregex --with-mhash --enable-zip --with-pcre-regex --enable-mysqlnd --with-mysql=mysqlnd --with-pdo-mysql=mysqlnd --with-mysqli=mysqlnd --with-jpeg-dir=/usr --with-png-dir=/usr --enable-gd-native-ttf --with-openssl --with-fpm-user=www-data --with-fpm-group=www-data --with-libdir=/lib/x86_64-linux-gnu --enable-ftp --with-gettext --enable-fpm --enable-bcmath --enable-dba --enable-exif --enable-intl --with-pspell --enable-shmop --with-snmp --with-tidy --enable-wddx --with-xmlrpc --with-xsl --with-imap --with-kerberos --with-imap-ssl --with-config-file-path=/opt/php${pv}/etc --with-config-file-scan-dir=/opt/php${pv}/etc/conf.d --enable-phar --with-recode=shared --disable-cli --enable-opcache strace -ff /opt/php7.0/sbin/php-fpm --fpm-config /opt/php7.0/etc/php-fpm.conf -c /opt/php7.0/etc/php.ini ... read(3, "3", 1) = 1 read(3, "2", 1) = 1 read(3, "M", 1) = 1 read(3, "\n", 1) = 1 read(3, "", 1) = 0 close(3) = 0 open("/var/log/apache2/php7.0-fpm.log", O_WRONLY|O_CREAT|O_APPEND, 0600) = 3 fcntl(3, F_GETFD) = 0 fcntl(3, F_SETFD, FD_CLOEXEC) = 0 stat("/var/www/default/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0 stat("/var/www/default/", {st_mode=S_IFDIR|0755, st_size=4096, ...}) = 0 open("/var/www/default/log/fpm.access.log", O_WRONLY|O_CREAT|O_APPEND, 0600) = 4 fcntl(4, F_GETFD) = 0 fcntl(4, F_SETFD, FD_CLOEXEC) = 0 geteuid() = 0 pipe([5, 6]) = 0 clone(Process 2025 attached child_stack=0, flags=CLONE_CHILD_CLEARTID|CLONE_CHILD_SETTID|SIGCHLD, child_tidptr=0x7f25e9f74a10) = 2025 [pid 2020] close(6) = 0 [pid 2020] select(6, [5], NULL, NULL, {10, 0} <unfinished ...> [pid 2025] close(5) = 0 [pid 2025] setsid() = 2025 [pid 2025] clock_gettime(CLOCK_MONOTONIC, {25683805, 950731931}) = 0 [pid 2025] geteuid() = 0 [pid 2025] brk(0x1b9f000) = 0x1b9f000 [pid 2025] socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0) = 5 [pid 2025] connect(5, {sa_family=AF_FILE, path="/var/run/nscd/socket"}, 110) = -1 ENOENT (No such file or directory) [pid 2025] close(5) = 0 [pid 2025] socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0) = 5 [pid 2025] connect(5, {sa_family=AF_FILE, path="/var/run/nscd/socket"}, 110) = -1 ENOENT (No such file or directory) [pid 2025] close(5) = 0 [pid 2025] open("/etc/ld.so.cache", O_RDONLY) = 5 [pid 2025] fstat(5, {st_mode=S_IFREG|0644, st_size=25565, ...}) = 0 [pid 2025] mmap(NULL, 25565, PROT_READ, MAP_PRIVATE, 5, 0) = 0x7f25e9e94000 [pid 2025] close(5) = 0 [pid 2025] access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory) [pid 2025] open("/lib/x86_64-linux-gnu/libnss_compat.so.2", O_RDONLY) = 5 [pid 2025] read(5, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0`\22\0\0\0\0\0\0"..., 832) = 832 [pid 2025] fstat(5, {st_mode=S_IFREG|0644, st_size=31584, ...}) = 0 [pid 2025] mmap(NULL, 2127048, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0x7f25e094c000 [pid 2025] mprotect(0x7f25e0953000, 2093056, PROT_NONE) = 0 [pid 2025] mmap(0x7f25e0b52000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x6000) = 0x7f25e0b52000 [pid 2025] close(5) = 0 [pid 2025] mprotect(0x7f25e0b52000, 4096, PROT_READ) = 0 [pid 2025] munmap(0x7f25e9e94000, 25565) = 0 [pid 2025] open("/etc/ld.so.cache", O_RDONLY) = 5 [pid 2025] fstat(5, {st_mode=S_IFREG|0644, st_size=25565, ...}) = 0 [pid 2025] mmap(NULL, 25565, PROT_READ, MAP_PRIVATE, 5, 0) = 0x7f25e9e94000 [pid 2025] close(5) = 0 [pid 2025] access("/etc/ld.so.nohwcap", F_OK) = -1 ENOENT (No such file or directory) [pid 2025] open("/lib/x86_64-linux-gnu/libnss_nis.so.2", O_RDONLY) = 5 [pid 2025] read(5, "\177ELF\2\1\1\0\0\0\0\0\0\0\0\0\3\0>\0\1\0\0\0p \0\0\0\0\0\0"..., 832) = 832 [pid 2025] fstat(5, {st_mode=S_IFREG|0644, st_size=43560, ...}) = 0 [pid 2025] mmap(NULL, 2139352, PROT_READ|PROT_EXEC, MAP_PRIVATE|MAP_DENYWRITE, 5, 0) = 0x7f25e0741000 [pid 2025] mprotect(0x7f25e074b000, 2093056, PROT_NONE) = 0 [pid 2025] mmap(0x7f25e094a000, 8192, PROT_READ|PROT_WRITE, MAP_PRIVATE|MAP_FIXED|MAP_DENYWRITE, 5, 0x9000) = 0x7f25e094a000 [pid 2025] close(5) = 0 [pid 2025] mprotect(0x7f25e094a000, 4096, PROT_READ) = 0 [pid 2025] munmap(0x7f25e9e94000, 25565) = 0 [pid 2025] open("/etc/passwd", O_RDONLY|O_CLOEXEC) = 5 [pid 2025] lseek(5, 0, SEEK_CUR) = 0 [pid 2025] fstat(5, {st_mode=S_IFREG|0644, st_size=86652, ...}) = 0 [pid 2025] mmap(NULL, 86652, PROT_READ, MAP_SHARED, 5, 0) = 0x7f25e9e85000 [pid 2025] lseek(5, 86652, SEEK_SET) = 86652 [pid 2025] munmap(0x7f25e9e85000, 86652) = 0 [pid 2025] close(5) = 0 [pid 2025] socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0) = 5 [pid 2025] connect(5, {sa_family=AF_FILE, path="/var/run/nscd/socket"}, 110) = -1 ENOENT (No such file or directory) [pid 2025] close(5) = 0 [pid 2025] socket(PF_FILE, SOCK_STREAM|SOCK_CLOEXEC|SOCK_NONBLOCK, 0) = 5 [pid 2025] connect(5, {sa_family=AF_FILE, path="/var/run/nscd/socket"}, 110) = -1 ENOENT (No such file or directory) [pid 2025] close(5) = 0 [pid 2025] open("/etc/group", O_RDONLY|O_CLOEXEC) = 5 [pid 2025] lseek(5, 0, SEEK_CUR) = 0 [pid 2025] fstat(5, {st_mode=S_IFREG|0644, st_size=28118, ...}) = 0 [pid 2025] mmap(NULL, 28118, PROT_READ, MAP_SHARED, 5, 0) = 0x7f25e9e94000 [pid 2025] lseek(5, 28118, SEEK_SET) = 28118 [pid 2025] munmap(0x7f25e9e94000, 28118) = 0 [pid 2025] close(5) = 0 [pid 2025] mmap(NULL, 152, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_ANONYMOUS, -1, 0) = 0x7f25e9e9a000 [pid 2025] mmap(NULL, 1168, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_ANONYMOUS, -1, 0) = 0x7f25e9e99000 [pid 2025] mmap(NULL, 1168, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_ANONYMOUS, -1, 0) = 0x7f25e9e98000 [pid 2025] mmap(NULL, 1168, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_ANONYMOUS, -1, 0) = 0x7f25e9e97000 [pid 2025] mmap(NULL, 1168, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_ANONYMOUS, -1, 0) = 0x7f25e9e96000 [pid 2025] mmap(NULL, 1168, PROT_READ|PROT_WRITE, MAP_SHARED|MAP_ANONYMOUS, -1, 0) = 0x7f25e9e95000 [pid 2025] --- SIGBUS (Bus error) @ 0 (0) --- Process 2025 detached <... select resumed> ) = 1 (in [5], left {9, 995055}) read(5, "", 4) = 0 --- SIGCHLD (Child exited) @ 0 (0) --- write(3, "[20-Nov-2015 09:42:12] ERROR: no"..., 63) = 63 write(2, "[20-Nov-2015 09:42:12] ERROR: no"..., 63[20-Nov-2015 09:42:12] ERROR: no data have been read from pipe ) = 63 exit_group(70) = ? -- Edit bug report at https://bugs.php.net/bug.php?id=70945&edit=1 -- Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=70945&r=trysnapshot54 Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=70945&r=trysnapshot55 Try a snapshot (trunk): https://bugs.php.net/fix.php?id=70945&r=trysnapshottrunk Fixed in SVN: https://bugs.php.net/fix.php?id=70945&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=70945&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=70945&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=70945&r=needscript Try newer version: https://bugs.php.net/fix.php?id=70945&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=70945&r=support Expected behavior: https://bugs.php.net/fix.php?id=70945&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=70945&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=70945&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=70945&r=globals PHP 4 support discontinued: https://bugs.php.net/fix.php?id=70945&r=php4 Daylight Savings: https://bugs.php.net/fix.php?id=70945&r=dst IIS Stability: https://bugs.php.net/fix.php?id=70945&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=70945&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=70945&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=70945&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=70945&r=mysqlcfg

« previous php.bugs (#197345) next »