Bug #15945: While starting Apache I get an undefined symbol error.

From: Date: Fri, 08 Mar 2002 03:53:01 +0000
Subject: Bug #15945: While starting Apache I get an undefined symbol error.
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-1979@lists.php.net to get a copy of this message
mysql_field_count From: tbirchmire@usa.net X-PHP-Bug: 15945 Message-ID: <bug-15945@bugs.php.net> From: tbirchmire@usa.net Operating system: RedHat 7.2 PHP version: 4.1.2 PHP Bug Type: MySQL related Bug description: While starting Apache I get an undefined symbol error. mysql_field_count While starting Apache I get an undefined symbol error. mysql_field_count Running RedHat 7.2 Installed MySQL 3.23.49a from binary into /usr/local/mysql from mysql-3.23.49a-pc-linux-gnu-i686. MySQL runs correctly. php-4.1.2.tar.gz untarred into php-4.1.2 build was ./configure "--with-mysql=/usr/local/mysql and --with-apxs=/usr/sbin/apxs" ran correctly (without error) make ran without error make install ran without error Apache won't start, reporting "undefined symbol" /etc/rc.d/init.d/httpd start Starting httpd: Syntax error on line 261 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: mysql_field_count [FAILED] -- Edit bug report at http://bugs.php.net/?id=15945&edit=1 -- Fixed in CVS: http://bugs.php.net/fix.php?id=15945&r=fixedcvs Fixed in release: http://bugs.php.net/fix.php?id=15945&r=alreadyfixed Need backtrace: http://bugs.php.net/fix.php?id=15945&r=needtrace Try newer version: http://bugs.php.net/fix.php?id=15945&r=oldversion Not developer issue: http://bugs.php.net/fix.php?id=15945&r=support Expected behavior: http://bugs.php.net/fix.php?id=15945&r=notwrong Not enough info: http://bugs.php.net/fix.php?id=15945&r=notenoughinfo Submitted twice: http://bugs.php.net/fix.php?id=15945&r=submittedtwice

« previous php.bugs (#1979) next »