Bug #71232 [Com]: outdated extension APIs for PHP 7.0.1 Windows build
| From: | mik2149 at gmail dot com | Date: | Wed, 20 Jan 2016 06:00:15 +0000 |
| Subject: | Bug #71232 [Com]: outdated extension APIs for PHP 7.0.1 Windows build | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-198785@lists.php.net to get a copy of this message | ||
Edit report at https://bugs.php.net/bug.php?id=71232&edit=1
ID: 71232
Comment by: mik2149 at gmail dot com
Reported by: jurchiks101 at gmail dot com
Summary: outdated extension APIs for PHP 7.0.1 Windows build
Status: Not a bug
Type: Bug
Package: Win32API related
Operating System: Windows 7 X64
PHP Version: 7.0.1
Block user comment: N
Private report: N
New Comment:
http: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
Apache 2.4 windows 7 x 64 error occurs with 3 extension needed for HttpResponse
error
Type: Error
Message: Class 'HttpResponse' not found
extension=php_raphf.dll
extension=php_propro.dll
extension=php_http.dll
it seems that they are not complied with php 7.0.1
Previous Comments:
------------------------------------------------------------------------
[2016-01-07 22:51:46] jurchiks101 at gmail dot com
It should treat extension_dir="ext" as a relative directory. It's just a logical
expectation that it would.
------------------------------------------------------------------------
[2016-01-07 17:36:07] ab@php.net
Thanks for the report. ZEND_EXTENSION_API_NO 20131226 corresponds to PHP 5.6. This means the
extensions DLLs are not loaded from the PHP 7 distribution. Please set an absolute path in the
extension_dir directive. Also please be sure using Apache compiled with VC14.
Thanks.
------------------------------------------------------------------------
[2016-01-06 00:20:32] jurchiks101 at gmail dot com
I also tried the QA release of 7.0.2RC1
VC14 x64 Thread Safe (2015-Dec-23 05:30:48)
And it had the exact same problem.
It looks like the person who compiles these doesn't even check if they work.
------------------------------------------------------------------------
[2015-12-28 20:37:13] jurchiks101 at gmail dot com
Description:
------------
I'm trying to run Apache 2.4 and PHP 7.0.1 on my Windows 7 x64 machine. When I start up the
Apache service, the Apache error log contains these messages:
PHP Warning: PHP Startup: curl: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
PHP Warning: PHP Startup: fileinfo: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
PHP Warning: PHP Startup: intl: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
PHP Warning: PHP Startup: mbstring: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
PHP Warning: PHP Startup: mysqli: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
PHP Warning: PHP Startup: openssl: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
PHP Warning: PHP Startup: pdo_mysql: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
PHP Warning: PHP Startup: soap: Unable to initialize module\nModule compiled with module
API=20131226\nPHP compiled with module API=20151012\nThese options need to match\n in Unknown on
line 0
This is a fresh download from http://windows.php.net/download/, it's "VC14
x64 Thread Safe (2015-Dec-17 00:17:17)".
All I have done in php.ini is set extension_dir="ext" (required, otherwise it tries to
load them from C:/php/) and enabled these extensions that fail to load, no other changes.
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=71232&edit=1