Bug #71427 [NEW]: v5.6.# version fails, Sun CC, cannot initialize function: SCNG

From: Date: Thu, 21 Jan 2016 18:22:30 +0000
Subject: Bug #71427 [NEW]: v5.6.# version fails, Sun CC, cannot initialize function: SCNG
Groups: php.bugs 
Request: Send a blank email to php-bugs+get-198823@lists.php.net to get a copy of this message
From: Christine dot Ross at healthstream dot com Operating system: Sparc Solaris 10 PHP version: 5.6.17 Package: Compile Failure Bug Type: Bug Bug description:v5.6.# version fails, Sun CC, cannot initialize function: SCNG Description: ------------ No problem building php 5.5.# with same configure script. Build fails with 5.6.#, Sun CC 12.3. Same results in v5.6.10 and 5.6.17. I tried without enabling opcache but that didn't help. Lots of white space character errors before it fails on line 70. I saw something about flex and re2c so I installed re2c, and it didn't help. Any help would be appreciated. "Zend/zend_language_scanner.l", line 66: warning: invalid white space character in directive "Zend/zend_language_scanner.l", line 67: warning: invalid white space character in directive "Zend/zend_language_scanner.l", line 68: warning: invalid white space character in directive "Zend/zend_language_scanner.l", line 69: warning: invalid white space character in directive "Zend/zend_language_scanner.l", line 70: warning: function prototype parameters must have types "Zend/zend_language_scanner.l", line 70: warning: old-style declaration or incorrect type for: SCNG "Zend/zend_language_scanner.l", line 70: cannot initialize function: SCNG "Zend/zend_language_scanner.l", line 70: undefined symbol: x #!/bin/sh # # Configure PHP # PATH=/usr/bin:/usr/local/bin:/usr/ccs/bin:/opt/SUNWspro/bin:/usr/sbin:/usr/dt/bin; export PATH LD_LIBRARY_PATH=/lib:/usr/lib:/usr/local/lib:/usr/local/ssl/lib; export LD_LIBRARY_PATH LD_RUN_PATH=/usr/local/ssl/lib:/usr/local/lib; export LD_RUN_PATH # env CC=cc CXX=CC \ ./configure \ --with-apxs2=/usr/local/apache2/bin/apxs \ --with-mysql=mysqlnd \ --with-pear \ --with-libxml-dir=/usr \ --with-mysqli=mysqlnd \ --with-pdo-mysql=mysqlnd \ --enable-mbstring \ --with-curl \ --with-gd \ --with-jpeg-dir=/usr/lib \ --enable-soap \ --with-openssl=/usr/local/ssl \ --enable-zip \ --with-iconv=/opt/local \ --enable-opcache #!/end # -- Edit bug report at https://bugs.php.net/bug.php?id=71427&edit=1 -- Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=71427&r=trysnapshot54 Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=71427&r=trysnapshot55 Try a snapshot (trunk): https://bugs.php.net/fix.php?id=71427&r=trysnapshottrunk Fixed in SVN: https://bugs.php.net/fix.php?id=71427&r=fixed Fixed in release: https://bugs.php.net/fix.php?id=71427&r=alreadyfixed Need backtrace: https://bugs.php.net/fix.php?id=71427&r=needtrace Need Reproduce Script: https://bugs.php.net/fix.php?id=71427&r=needscript Try newer version: https://bugs.php.net/fix.php?id=71427&r=oldversion Not developer issue: https://bugs.php.net/fix.php?id=71427&r=support Expected behavior: https://bugs.php.net/fix.php?id=71427&r=notwrong Not enough info: https://bugs.php.net/fix.php?id=71427&r=notenoughinfo Submitted twice: https://bugs.php.net/fix.php?id=71427&r=submittedtwice register_globals: https://bugs.php.net/fix.php?id=71427&r=globals PHP 4 support discontinued: https://bugs.php.net/fix.php?id=71427&r=php4 Daylight Savings: https://bugs.php.net/fix.php?id=71427&r=dst IIS Stability: https://bugs.php.net/fix.php?id=71427&r=isapi Install GNU Sed: https://bugs.php.net/fix.php?id=71427&r=gnused Floating point limitations: https://bugs.php.net/fix.php?id=71427&r=float No Zend Extensions: https://bugs.php.net/fix.php?id=71427&r=nozend MySQL Configuration Error: https://bugs.php.net/fix.php?id=71427&r=mysqlcfg

« previous php.bugs (#198823) next »