Bug #15945 Updated: While starting Apache I get an undefined symbol error.mysql_field_count

From: Date: Fri, 08 Mar 2002 08:00:29 +0000
Subject: Bug #15945 Updated: While starting Apache I get an undefined symbol error.mysql_field_count
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-1991@lists.php.net to get a copy of this message
ID: 15945 Updated by: sniper@php.net -Summary: While starting Apache I get an undefined symbol error. mysql_field_count Reported By: tbirchmire@usa.net -Status: Open +Status: Feedback Bug Type: MySQL related Operating System: RedHat 7.2 PHP Version: 4.1.2 New Comment: Try checking first that the libphp4.so is finding all necessary libraries: # ldd /etc/httpd/modules/libphp4.so As you might not have /usr/local/mysql/lib/mysql/ in your /etc/ld.so.conf Try adding it and run /sbin/ldconfig --Jani Previous Comments: ------------------------------------------------------------------------ [2002-03-07 22:53:01] tbirchmire@usa.net While starting Apache I get an undefined symbol error. mysql_field_count Running RedHat 7.2 Installed MySQL 3.23.49a from binary into /usr/local/mysql from mysql-3.23.49a-pc-linux-gnu-i686. MySQL runs correctly. php-4.1.2.tar.gz untarred into php-4.1.2 build was ./configure "--with-mysql=/usr/local/mysql and --with-apxs=/usr/sbin/apxs" ran correctly (without error) make ran without error make install ran without error Apache won't start, reporting "undefined symbol" /etc/rc.d/init.d/httpd start Starting httpd: Syntax error on line 261 of /etc/httpd/conf/httpd.conf: Cannot load /etc/httpd/modules/libphp4.so into server: /etc/httpd/modules/libphp4.so: undefined symbol: mysql_field_count [FAILED] ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=15945&edit=1

« previous php.bugs (#1991) next »