Bug #71440 [Opn->Wfx]: Please, don't raise error if no default pool conffile file is present (PHP-FPM)

From: Date: Sun, 27 Mar 2016 06:04:12 +0000
Subject: Bug #71440 [Opn->Wfx]: Please, don't raise error if no default pool conffile file is present (PHP-FPM)
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-200143@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=71440&edit=1 ID: 71440 Updated by: krakjoe@php.net Reported by: l dot declercq at nuxwin dot com Summary: Please, don't raise error if no default pool conffile file is present (PHP-FPM) -Status: Open +Status: Wont fix Type: Bug Package: FPM related Operating System: Any PHP Version: 7.0.2 Block user comment: N Private report: N New Comment: We would break expectations (and probably deploys) if we changed something that used to emit an error, to fail silently ... we cannot reasonably do this. Previous Comments: ------------------------------------------------------------------------ [2016-01-24 14:16:06] l dot declercq at nuxwin dot com Description: ------------ Hello, I'm wondering why an error is raised when no default pool configuration file is present. For instance, for Debian, the package maintainer configures a default pool configuration file set with the www-data user. This fulfills default installation requirements for Debian, but in some cases, we would expect no default pool configuration file. For instance, we're providing a control panel which allows to manage shared hosting environments . Mutliple PHP versions are provided through the panel (through PHP-FPM). First of all, it should be noted that for security reasons, we never run PHP through the www-data user. PHP is run through dedicated unix users (one for each customer). So here, we don't need to have a default pool configuration set with www-data user, which will never be used. Thefore, on installation, this default file is removed by our backend. To resume, when rebooting or when restarting the PHP-FPM instance, there should be no error when no pool file configuration is available. Instead, the daemon should not start (silently). ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=71440&edit=1

« previous php.bugs (#200143) next »