Bug #72332 [NEW]: Enabling opcache on multiple sites results in 500 error
From: epinci at tiscali dot it
Operating system: WinSrv2012
PHP version: 7.0.7
Package: IIS related
Bug Type: Bug
Bug description:Enabling opcache on multiple sites results in 500 error
Description:
------------
If:
> you are runnin PHP in IIS with Zend Opcode extension enabled
> you have multiple sites whose AppPools are running in the same
security context (user)
then:
> the first site that gets called after an apppool recycle works fine
> all others fails with 500 server error.
If you have opcache logging turned on you get: "Fatal Error Cannot
create mutex" in the log.
It seems the opcache code shared_alloc_win32.c, function
get_mmap_base_file creates and locks a file
C:\Windows\Temp\ZendOPcache.MemoryBase@<User.Name>@<fixedGUID> which
makes it impossible to use Opcode caching under more than one install of
PHP under the same user account.
It also seems that the fixedGuid is fixed in all site's opcache file.
Should'nt it be variable? What is the use of adding it to the file name
if it is always the same?
--
Edit bug report at https://bugs.php.net/bug.php?id=72332&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=72332&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=72332&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=72332&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=72332&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=72332&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=72332&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=72332&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=72332&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=72332&r=support
Expected behavior: https://bugs.php.net/fix.php?id=72332&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=72332&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=72332&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=72332&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=72332&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=72332&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=72332&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=72332&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=72332&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=72332&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=72332&r=mysqlcfg
Thread (3 messages)
- epinci at tiscali dot it