Bug #72544 [Opn->Fbk]: pg_connect using the "service" parameter

From: Date: Thu, 07 Jul 2016 05:30:10 +0000
Subject: Bug #72544 [Opn->Fbk]: pg_connect using the "service" parameter
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-202113@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=72544&edit=1 ID: 72544 Updated by: requinix@php.net Reported by: floriparob at gmail dot com Summary: pg_connect using the "service" parameter -Status: Open +Status: Feedback Type: Bug Package: PostgreSQL related Operating System: Debian PHP Version: 5.6.23 Block user comment: N Private report: N New Comment: Make sure you're looking at the pg_service.conf file located somewhere within /etc/postgresql and not one in another directory, like your home directory. Or possibly in the home directory of whatever user PHP is running as. It can also vary with the PGSERVICEFILE or PGSYSCONFDIR environment variables. > So how does php5-pgsql set the PGSERVICE environment variable? It does not. The environment variables are fallback behavior for information not provided in the connection string, so if you try to connect with "service=staging" then libpq won't look for a PGSERVICE. The connection string is passed to PQconnectStart (if async) or PQconnectdb without much modification. https://www.postgresql.org/docs/current/static/libpq-connect.html > Should we upgrade to PHP7? Shouldn't matter for this. PHP 5.6 is still in active support so 5.6.x and 7.0.y will be more or less equal in terms of bug fixes and such. Previous Comments: ------------------------------------------------------------------------ [2016-07-06 22:09:17] floriparob at gmail dot com The error message is:- PHP Warning: pg_connect(): Unable to connect to PostgreSQL server: definition of service "staging" not found If it were a permissions issue I'd expect to see "cannot stat" etc. as the error message. I had a look at the libpq source, in particular fe_connect.c, and it requires the environment variables PGSERVICE and PGSERVICEFILE in order to connect, obtaining the "key" from PGSERVICE and then looking up the connect parameters in pg_service.conf whose path is defined in PGSERVICEFILE. This works with psql. So how does php5-pgsql set the PGSERVICE environment variable? Should we upgrade to PHP7? ------------------------------------------------------------------------ [2016-07-05 07:29:46] requinix@php.net It seems to be supported as far as I can tell. What's the error message? ------------------------------------------------------------------------ [2016-07-05 02:19:56] floriparob at gmail dot com Description: ------------ The documentation for pg_connect says that it recognises the "service" parameter as a connect string. In the pg_service.conf file you can have entries for several databases, each with their own distinct IP addresses, passwords, etc. So, in your PHP code you'd expect to be able to do something like this wrapped up in a try catch block:- $connect_string = "service=staging"; $pg_handle = pg_connect($connect_string); to access the "staging" data base. With psql you have to do this:- PGSERVICE=staging;export PGSERVICE psql is run without any parameters. It opens the pg_service.conf file and finds the entry defined as "staging" and from that obtains all the necessary configuration parameters in order to open a connection to that database. I tried this:- putenv("PGSERVICE=staging"); $connect_string = "service=staging"; $pg_handle = pg_connect($connect_string); but still no luck. So, if this is not a bug could somebody please enlighten me about the correct way to connect using pg_service.conf. ------------------------------------------------------------------------ -- Edit this bug report at https://bugs.php.net/bug.php?id=72544&edit=1

« previous php.bugs (#202113) next »