#14483 [Com]: -twolevel_namespace and multiple definitions errors
| From: | brian dot paquin at yale dot edu | Date: | Tue, 24 Sep 2002 17:59:14 +0000 |
| Subject: | #14483 [Com]: -twolevel_namespace and multiple definitions errors | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-20217@lists.php.net to get a copy of this message | ||
ID: 14483
Comment by: brian.paquin@yale.edu
Reported By: abner@criticalnexus.com
Status: Closed
Bug Type: Compile Failure
Operating System: Mac OS X 10.1
PHP Version: 4.2.0-dev
New Comment:
Thanks for pointing me to snaps! Config went much
smoother, however I get the following error from Apache:
[path046:/Users/bripakes] bripakes# apachectl start
Syntax error on line 242 of /etc/httpd/httpd.conf:
Cannot load /usr/libexec/httpd/libphp4.so into server:
(reason unknown)
/usr/sbin/apachectl start: httpd could not be started
I noticed the owner and group were different so I changed
them to root/wheel. And PEAR gave me errors so I used
--disable-pear in my config.
Any ideas?
Previous Comments:
------------------------------------------------------------------------
[2002-09-24 12:15:58] abner@criticalnexus.com
I notice you're logged in as "bripakes". I think you need to be "root"
to control apache, and it's even best if you install it as "root".
Forget "sudo" and all of that happy bull. Just "su" and do what you
need to do, then go back to being a normal user. If you're still
confused, read the following logs, they should provide some guidance:
tail -50 /var/log/system.log
tail -50 /var/log/httpd/error_log
-Abner
------------------------------------------------------------------------
[2002-09-24 12:07:38] brian.paquin@yale.edu
Thanks for pointing me to snaps! Config went much
smoother, however I get the following error from Apache:
[path046:/Users/bripakes] bripakes# apachectl start
Syntax error on line 242 of /etc/httpd/httpd.conf:
Cannot load /usr/libexec/httpd/libphp4.so into server:
(reason unknown)
/usr/sbin/apachectl start: httpd could not be started
I noticed the owner and group were different so I changed
them to root/wheel. And PEAR gave me errors so I used
--disable-pear in my config.
Any ideas?
------------------------------------------------------------------------
[2002-09-23 13:48:54] abner@criticalnexus.com
Use PHP 4.3.0-dev from http://snaps.php.net
http://panther.criticalnexus.com/info.php
-Abner
------------------------------------------------------------------------
[2002-09-23 13:10:49] brian.paquin@yale.edu
PHP 4.2.3 fails 'make install' with:
Making install in .
/usr/src/php-4.2.3/build/shtool mkdir -p "/usr/libexec/
httpd" && apxs -S LIBEXECDIR="/usr/libexec/httpd" -i -a -n
php4 libs/libphp4.dylib
apxs:Error: file libs/libphp4.dylib is not a DSO
make[1]: *** [install-sapi] Error 1
make: *** [install-recursive] Error 1
Any suggestions?
I'm using 10.2.1 with Apache 1.3.26 (Darwin), Sybase 12.5,
and PHP 4.2.3...
Tried both Marc Liyanage's site and Tenon's iTools site
instructions, and both give same error...
Bri
------------------------------------------------------------------------
[2002-04-23 14:27:26] liyanage@access.ch
Using the helpful and informative comments on this page I made a patch
which can be applied against the 4.2.0 release source distribution.
The basic 4.2.0 module compiles fine for me with the patch.
It is available at
http://www.entropy.ch/software/macosx/php/php-4.2.0-entropy.ch.patch
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/14483
--
Edit this bug report at http://bugs.php.net/?id=14483&edit=1