#14483 [Com]: -twolevel_namespace and multiple definitions errors
| From: | brian dot paquin at yale dot edu | Date: | Tue, 24 Sep 2002 19:32:55 +0000 |
| Subject: | #14483 [Com]: -twolevel_namespace and multiple definitions errors | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-20225@lists.php.net to get a copy of this message | ||
ID: 14483
Comment by: brian.paquin@yale.edu
Reported By: abner@criticalnexus.com
Status: Closed
Bug Type: Compile Failure
Operating System: Mac OS X 10.1
PHP Version: 4.2.0-dev
New Comment:
Eveything I did was in root (su)...
system.log shows:
Sep 24 11:31:00 path046 SystemStarter: Apache web server
(446) did not complete successfully.
httpd/error_log shows nothing significant (previous errors
when running).
I'll look into pear I suppose...
Brian
Previous Comments:
------------------------------------------------------------------------
[2002-09-24 13:25:58] brian.paquin@yale.edu
Eveything I did was in root (su)...
system.log shows:
Sep 24 11:31:00 path046 SystemStarter: Apache web server
(446) did not complete successfully.
httpd/error_log shows nothing significant (previous errors
when running).
I'll look into pear I suppose...
Brian
------------------------------------------------------------------------
[2002-09-24 12:59:13] brian.paquin@yale.edu
Thanks for pointing me to snaps! Config went much
smoother, however I get the following error from Apache:
[path046:/Users/bripakes] bripakes# apachectl start
Syntax error on line 242 of /etc/httpd/httpd.conf:
Cannot load /usr/libexec/httpd/libphp4.so into server:
(reason unknown)
/usr/sbin/apachectl start: httpd could not be started
I noticed the owner and group were different so I changed
them to root/wheel. And PEAR gave me errors so I used
--disable-pear in my config.
Any ideas?
------------------------------------------------------------------------
[2002-09-24 12:15:58] abner@criticalnexus.com
I notice you're logged in as "bripakes". I think you need to be "root"
to control apache, and it's even best if you install it as "root".
Forget "sudo" and all of that happy bull. Just "su" and do what you
need to do, then go back to being a normal user. If you're still
confused, read the following logs, they should provide some guidance:
tail -50 /var/log/system.log
tail -50 /var/log/httpd/error_log
-Abner
------------------------------------------------------------------------
[2002-09-24 12:07:38] brian.paquin@yale.edu
Thanks for pointing me to snaps! Config went much
smoother, however I get the following error from Apache:
[path046:/Users/bripakes] bripakes# apachectl start
Syntax error on line 242 of /etc/httpd/httpd.conf:
Cannot load /usr/libexec/httpd/libphp4.so into server:
(reason unknown)
/usr/sbin/apachectl start: httpd could not be started
I noticed the owner and group were different so I changed
them to root/wheel. And PEAR gave me errors so I used
--disable-pear in my config.
Any ideas?
------------------------------------------------------------------------
[2002-09-23 13:48:54] abner@criticalnexus.com
Use PHP 4.3.0-dev from http://snaps.php.net
http://panther.criticalnexus.com/info.php
-Abner
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/14483
--
Edit this bug report at http://bugs.php.net/?id=14483&edit=1