Edit report at https://bugs.php.net/bug.php?id=73183&edit=1
ID: 73183
Updated by: laruence@php.net
Reported by: schnederle at futureweb dot at
Summary: Segfaults / zend_mm_heap corrupted
Status: Open
Type: Bug
Package: Reproducible crash
Operating System: Centos 7.2.1511
PHP Version: 7.0.11
Block user comment: N
Private report: N
New Comment:
paste the backtrace out (coredump)
Previous Comments:
------------------------------------------------------------------------
[2016-09-28 11:25:50] schnederle at futureweb dot at
again Segfaults with opcache.protect_memory=1:
[Wed Sep 28 13:22:25.387677 2016] [core:notice] [pid 25800] AH00052: child pid 4680 exit signal
Segmentation fault (11)
...
[Wed Sep 28 13:22:46.415573 2016] [core:notice] [pid 25800] AH00052: child pid 4885 exit signal
Segmentation fault (11)
------------------------------------------------------------------------
[2016-09-28 08:01:54] schnederle at futureweb dot at
alright - I activated protect_memory and will report back.
Will I see Errors in the Logs when there are any unexpected writes to shared memory? (unfortunately
there is not much documentation available what protect_memory excactly does)
------------------------------------------------------------------------
[2016-09-28 03:39:24] laruence@php.net
you may try to set opcache.protect_memory=1 (please note this will significantly slowdown the
server). and see if there is any unexpected write to shared memory
------------------------------------------------------------------------
[2016-09-27 12:13:10] schnederle at futureweb dot at
Description:
------------
Hello,
since we switched from PHP 5.3 to PHP 7.0.x (tried multiple Versions of PHP 7 - now we are on
7.0.11) we get random segfaults / zend_mm_heap corrupted with our CMS.
Unfortunately not predictable when they will occur or on which Script. (unfortunately never the
same)
Sometimes a few Days no problems - sometimes 5 times a Day ...
Not 100% sure - but I believe that opcache could be the cause of the Problem - as a simple
"opcache_reset();" is enough to get everything up & running again - no complete
restart of Apache needed.
Error Log / Backtrace: http://temp.in.futureweb.at/php/error.log
Hope someone can help me on this ...
Thank you
Andreas Schnederle-Wagner
------------------------------------------------------------------------
--
Edit this bug report at https://bugs.php.net/bug.php?id=73183&edit=1