#19219 [Opn]: Cannot build with-informix for Apache DSO

From: Date: Fri, 27 Sep 2002 04:43:05 +0000
Subject: #19219 [Opn]: Cannot build with-informix for Apache DSO
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-20552@lists.php.net to get a copy of this message
ID: 19219 User updated by: jerrysmith@directvinternet.com Reported By: jerrysmith@directvinternet.com Status: Open Bug Type: Informix related Operating System: HPUX 11.0 PHP Version: 4.2.2 New Comment: HELP! I'm dying here. If I don't get this running I may loose a consulting contract! Whats the process to get a developer to take a look here? Previous Comments: ------------------------------------------------------------------------ [2002-09-09 19:50:31] jerrysmith@directvinternet.com ANYONE ELSE UP TO THE CHALLENGE??? ...here is the contents of the ext dir of PHP for Informix [hpserv02] ls .deps Makefile ifx.c ifx.lo libs.mk stub.c .libs Makefile.in ifx.dsp libinformix.la php_informix.h CREDITS config.m4 ifx.ec libphpifx.a setup.stub ..the .lib DIR contains.. [hpserv02] ls -al .libs -rw-rw-rw- 1 root sys 321104 Sep 9 19:55 libinformix.al lrwxrwxrwx 1 root sys 17 Sep 9 19:55 libinformix.la -> ../libinformix.la ALSO.. [hpserv02] [hpserv02] ls /usr/informix/lib esql iasft07b.sl libixasf.a libtasf.a netstub.a sqlexecd iasfs07a.sl libasf.a libixasf.sl libtasf.sl sqlexec sqlexecd.old iasfs07b.sl libasf.sl libnetstub.sl netlib.a sqlexec.old sqlrm [hpserv02] [hpserv02] ls /usr/informix/lib/esql checkapi.o igl4a303.sl isqlt07a.sl libgls.a libixgen.sl libixos.a libos.sl libtos.a esqlc iglxa303.sl isxas07a.sl libglx.a libixgls.a libixos.sl libsql.a libtos.sl esqlmf iosls07a.sl ixacursor.o libinfxxa.a libixgls.sl libixsql.a libsql.sl libtsql.a igens07a.sl ioslt07a.sl libgen.a libinfxxa.sl libixglx.a libixsql.sl libtgen.a libtsql.sl igent07a.sl isqls07a.sl libgen.sl libixgen.a libixglx.sl libos.a libtgen.sl [hpserv02] ------------------------------------------------------------------------ [2002-09-04 19:40:23] sniper@php.net I think libtool sucks. And I'm out of ideas. ------------------------------------------------------------------------ [2002-09-04 17:37:33] jerrysmith@directvinternet.com No such luck. The standard build with: ./configure --with-apxs=/usr/informix/apache/bin/apxs --with-mysql=no Resulted in.... . . *** Warning: This library needs some functionality provided by -lcrypt....*** I have the capability to make that..... *** Warning: libtool could not satisfy all declared inter-library*** dependencies of module libphp4. Therefore, libtool will create *** a static module, that should work as long as the dlopening *** application is linked with the -dlopen flag. Installing PHP SAPI module apxs:Error: file libs/libphp4.sl is not a DSO *** Error exit code 1 Stop. =============================================== the libs directory contained two libraries... libphp4.a libphp4.la I copied them to the apache modules dir and updated the httpd.conf to include them....when starting get the error: [hpserv02] ./apachectl start /usr/lib/dld.sl: Bad magic number for shared library: /usr/local/apache/lib/modules/libphp4.la /usr/lib/dld.sl: Exec format error Syntax error on line 236 of /usr/local/apache/etc/httpd.conf: Cannot load /usr/local/apache/lib/modules/libphp4.la into server: Exec format error ./apachectl start: httpd could not be started --------- Since I cannot rebuild the Apache, I must have an Informix make file that includes the proper shared library. This seems to me to be the simplest solution..(and use the 4.2.2 source for the build) What do you think? Thanks Jerry ------------------------------------------------------------------------ [2002-09-04 13:22:33] sniper@php.net Did the snapshot work (ie. compile correct file) without informix then? ------------------------------------------------------------------------ [2002-09-04 13:08:59] jerrysmith@directvinternet.com It did not build a libphp4.sl, but a libphp4.lc whatever that is. I tried copying it and still got the exec error. Since I can successfully build and run a PHP moduled for the Apache WITHOUT the Informix, I believe that the portion of the makefile simply needs to be modified to use the correct "shared" version of the libraries needed. Thanks for your help Jerry ------------------------------------------------------------------------ The remainder of the comments for this report are too long. To view the rest of the comments, please view the bug report online at http://bugs.php.net/19219 -- Edit this bug report at http://bugs.php.net/?id=19219&edit=1

« previous php.bugs (#20552) next »