Bug #73598 [NEW]: Getting zend_mm_heap corrupted in error_log, website fails to load
| From: | andy at greenrobot dot com | Date: | Thu, 24 Nov 2016 05:27:48 +0000 |
| Subject: | Bug #73598 [NEW]: Getting zend_mm_heap corrupted in error_log, website fails to load | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-205590@lists.php.net to get a copy of this message | ||
From: andy at greenrobot dot com
Operating system: CentOS Linux release 7.2.1511 (C
PHP version: 5.6.28
Package: opcache
Bug Type: Bug
Bug description:Getting zend_mm_heap corrupted in error_log, website fails to load
Description:
------------
I am experiencing a 'zend_mm_heap corrupted' in my Apache error logs. I
have upgraded my server to the latest available with Yum and also
upgraded to the latest 5.6 PHP. This happens with an open source
adserver that we developed using Laravel:
https://github.com/greenrobotllc/adserver.
On my site it is serving
about 50K impressions per day and getting this error sporadically.
I am using PHP 5.6.28 with Opcache enabled. See my PHP info here:
https://greenrobot.com/phpinfo.php.
I have noticed before that the errors will kind of pile up after awhile
and I will be forced to restart Apache because the adserver has stopped
working at all, which fixes it for awhile.
In addition to upgrading to the latest PHP 5.6 and Centos package
versions, I upgraded my Laravel app to use Laravel 5.3.
Test script:
---------------
https://github.com/greenrobotllc/adserver
Expected result:
----------------
No zend errors.
Actual result:
--------------
'zend_mm_heap corrupted' in my Apache error logs.
--
Edit bug report at https://bugs.php.net/bug.php?id=73598&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=73598&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=73598&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=73598&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=73598&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=73598&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=73598&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=73598&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=73598&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=73598&r=support
Expected behavior: https://bugs.php.net/fix.php?id=73598&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=73598&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=73598&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=73598&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=73598&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=73598&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=73598&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=73598&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=73598&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=73598&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=73598&r=mysqlcfg