Edit report at https://bugs.php.net/bug.php?id=64549&edit=1
ID: 64549
Comment by: steffen dot weber at gmail dot com
Reported by: rgagnon24 at gmail dot com
Summary: mysqlnd persistent connection handling out of
control
Status: Open
Type: Bug
Package: MySQL related
Operating System: CentOS 5.9
PHP Version: 5.3.23
Block user comment: N
Private report: N
New Comment:
I've just run into the problem that PDO::__construct emits a needless warning 'MySQL
server has gone away' when a persistent connection was closed remotely (e.g. by a MySQL server
restart). Since the connection is automatically reestablished there is no need for such a warning.
I did not know that you could use the '@'-error-control-operator to suppress the
unnecessary warning without suppressing exceptions, too. Thank you for the hint, rgagnon24!
Previous Comments:
------------------------------------------------------------------------
[2014-10-30 13:39:47] patryk dot kozlowski at toxic-software dot pl
PHP Warning: PDO::__construct(): MySQL server has gone away in <filepath> on line
<line_number> - this error still occurs randomly on lastes versions of php-5.5 and php-5.6
------------------------------------------------------------------------
[2013-06-14 05:13:59] rgagnon24 at gmail dot com
Related To: Bug #64993
------------------------------------------------------------------------
[2013-06-14 05:09:14] rgagnon24 at gmail dot com
The solution may lie in the patch attached to bug 64993 which does not clear a reference or free
memory when a failed SQL happens.
------------------------------------------------------------------------
[2013-06-07 10:00:45] uw@php.net
PDO - that's the thing that does its own pooling, isn't it? Wondering if this is MySQL
specific at all...
------------------------------------------------------------------------
[2013-04-02 16:48:20] rgagnon24 at gmail dot com
Question: Why is there a gtk window git pull request recorded on this bug?
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
https://bugs.php.net/bug.php?id=64549
--
Edit this bug report at https://bugs.php.net/bug.php?id=64549&edit=1