Bug #74080 [NEW]: Provide an RFC7231 date time format
| From: | neclimdul at gmail dot com | Date: | Fri, 10 Feb 2017 19:27:22 +0000 |
| Subject: | Bug #74080 [NEW]: Provide an RFC7231 date time format | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-207257@lists.php.net to get a copy of this message | ||
From: neclimdul at gmail dot com
Operating system:
PHP version: 7.1.1
Package: *General Issues
Bug Type: Bug
Bug description:Provide an RFC7231 date time format
Description:
------------
There are a number of useful constants for formatting dates in PHP which
cover most of the formats used on the internet. Unfortunately there is
one missing format which can be pretty important, the one defined by
RFC2616.
All HTTP headers should follow this format. Because its a subset of
RFC1123 that format is commonly substituted in PHP. This generally will
work with permissive systems, however because the format provided by
RFC1123 is system dependent it can provide strings that with more strict
proxies will fail to parse. Generally that is UTC instead of the
required GMT timezone. And old php.net documentation comment mentions
this as well http://php.net/gmdate#25031.
Because of this Drupal has a custom constant to be used in headers
https://www.drupal.org/node/1918820
However because of PHP's audience I think it would be a handy feature
for everyone to have the additional format constant.
RFC2616 is actually obsoleeted by RFC7231 in 2014 so I would use this
name as Drupal did but the format is the same.
https://www.w3.org/Protocols/rfc2616/rfc2616-sec3.html#sec3.3
http://tools.ietf.org/html/rfc7231#section-7.1.1.1
--
Edit bug report at https://bugs.php.net/bug.php?id=74080&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=74080&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=74080&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=74080&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=74080&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=74080&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=74080&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=74080&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=74080&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=74080&r=support
Expected behavior: https://bugs.php.net/fix.php?id=74080&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=74080&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=74080&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=74080&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=74080&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=74080&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=74080&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=74080&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=74080&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=74080&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=74080&r=mysqlcfg