#4211 [Opn->Bgs]: Apahce fails to load libphp4.so
| From: | hholzgra@php.net | Date: | Tue, 01 Oct 2002 00:49:32 +0000 |
| Subject: | #4211 [Opn->Bgs]: Apahce fails to load libphp4.so | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-20846@lists.php.net to get a copy of this message | ||
ID: 4211
Updated by: hholzgra@php.net
Reported By: tim@tjkern.com
-Status: Open
+Status: Bogus
Bug Type: Oracle related
Operating System: RedHat 6.2 (2.2.14)
PHP Version: 3.0.16
New Comment:
Thank you for taking the time to report a problem with PHP.
Unfortunately you are not using a current version of PHP --
the problem might already be fixed. Please download a new
PHP version from http://www.php.net/downloads.php
If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.
Previous Comments:
------------------------------------------------------------------------
[2000-04-20 17:51:33] tim@tjkern.com
Hardware:
DELL XPST PIII 500MHz
256M RAM
Software:
Orcale 8.1.5.2
RedHat 6.2
Apache 1.3.12
PHP 4.0 RC1
Env:
$ORACLE_HOME, $ORACLE_SID, standard paths for root
bash shell
apache command line:
./configure --with-prefix=/my/path \
--enable-modules=all \
--enable-shared=max \
--enable-module=rewrite \
--enable-shared=rewrite
...no errors...httpd starts normally...
php command line:
./configure --with-oracle --with-apxs=/path/to --with-track-vars
...compiles/installs without error...
After installation, I try to restart apache and get the error:
Cannot load /path/libphp4.so into server: libclntsh.so.8.0 cannot open
shared library or object: No such file or directory
...it looks like it could be a permission problem...I've seen the
problem before with Oracle installations...it occurs after an Oracle
install when trying to run svrmgrl or other apps...the cure is to run
$ORACLE_HOME/install/utl/linux.sh...I tried to apply that fix, but it
hosed my Oracle installation...anyway, if I can help you track this one
down, just send me a note...
NOTE: php 3.16 works fine with the Oracle installation
Tim Kern
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=4211&edit=1