#14118 [Com]: Upload file more than 1 Mb doesn´t work
| From: | jbyu at csie dot nctu dot edu dot tw | Date: | Tue, 01 Oct 2002 16:08:06 +0000 |
| Subject: | #14118 [Com]: Upload file more than 1 Mb doesn´t work | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-20952@lists.php.net to get a copy of this message | ||
ID: 14118
Comment by: jbyu@csie.nctu.edu.tw
Reported By: mlara@gcintl.com
Status: Closed
Bug Type: Unknown/Other Function
Operating System: linux redhat 7.1
PHP Version: 4.0.4pl1
New Comment:
I have same problem about upload large file.
My platform: Win2k + Apache 2.0.42 + PHP 4.1.2
The php.ini is also correct.
So what do i miss? httpd.conf?
Previous Comments:
------------------------------------------------------------------------
[2001-11-21 14:14:19] mlara@gcintl.com
Thanks
I resolved my problem, the reason was that the squid configuration
limit the request size, I changed this value and I can upload file more
higher than 2 Mb .
Thanks for all, I´m sorry
Mauricio
------------------------------------------------------------------------
[2001-11-21 12:42:44] sniper@php.net
Please try with PHP 4.1.0RC3:
http://download.php.net/~zeev/php-4.1.0RC3.tar.gz
------------------------------------------------------------------------
[2001-11-20 09:16:58] mlara@gcintl.com
My php.ini has track_errors = On
but the script return the same error "The page cannot be
displayed". when I try to upload a file higher 2 Mb, I´ve changed all
in my script and my php.ini but doesn´t work, please can you help me
suggest me another solution.
My script printed the post variables, if the file is lower than 2 mb
the variables are printed, but if the file is higher 2 mb I get the
error "The page cannot be
displayed", and the variables aren´t printed.
Maybe my apache.conf file has a error.Please help me
Thanks
------------------------------------------------------------------------
[2001-11-19 18:43:44] sniper@php.net
This script works for me just fine. Note that to be
able to see the error message, you need to have this
directive enabled in php.ini:
track_errors = On
Also note that if MAX_FILE_SIZE is used and is set
to lower than the values in php.ini it will override them.
And the value it sets is in bytes.
--------test.php---------
<?php
print_r($HTTP_POST_FILES);
echo $php_errormsg;
?>
<FORM ENCTYPE="multipart/form-data" ACTION="test.php" METHOD=POST>
<INPUT TYPE="hidden" name="MAX_FILE_SIZE" value="1024000">
<INPUT NAME="UploadedFile" TYPE="file">
<INPUT TYPE="hidden" name="set" value="go">
<INPUT TYPE="submit" VALUE="Upload">
</FORM>
</BODY>
</HTML>
--------test.php---------
------------------------------------------------------------------------
[2001-11-19 13:59:48] mlara@gcintl.com
My apache version is: Apache/1.3.14
I use internet explorer 5.5 and netscape 4.75 but the problem persist
I erased the line <INPUT TYPE="hidden" name="MAX_FILE_SIZE"
value="1024000"> but doesn´t work.
If you see my script I print the upload variables, if I upload a file
lower 2 Mb, the variables are printed, but if I transfer a higher file
the variables aren´t printed and not copy the file in server.
Thanks
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/14118
--
Edit this bug report at http://bugs.php.net/?id=14118&edit=1