Bug #74774 [NEW]: file(): http:// wrapper is disabled after upgrade to PHP 7.1.6
| From: | mumu at seznam dot cz | Date: | Sun, 18 Jun 2017 12:05:13 +0000 |
| Subject: | Bug #74774 [NEW]: file(): http:// wrapper is disabled after upgrade to PHP 7.1.6 | ||
| Groups: | php.bugs | ||
| Request: | Send a blank email to php-bugs+get-209573@lists.php.net to get a copy of this message | ||
From: mumu at seznam dot cz
Operating system: Windows Server 2016
PHP version: 7.1.6
Package: Unknown/Other Function
Bug Type: Bug
Bug description:file(): http:// wrapper is disabled after upgrade to PHP 7.1.6
Description:
------------
I started to get
file(): http:// wrapper is disabled in the server configuration by
allow_url_fopen=0
file(http://www.cnb.cz/cs/financni_trhy/devizovy_trh/kurzy_devizoveho_trhu/denni_kurz.txt?date=17.06.2017):
failed to open stream: no suitable wrapper could be found
after upgrading from PHP 7.1.5 to 7.1.6.
The error disappears after downgrading back to 7.1.5.
No configuration change has been made. Just overwriting files from the
windows distribution package for the respective NTS VC14 x64 version.
I have double checked the change logs but found nothing relevant.
The php.ini contains per-directory settings of allow_url_fopen.
The following line throws the error:
$lines = file($url, FILE_IGNORE_NEW_LINES);
where
$url was
http://www.cnb.cz/cs/financni_trhy/devizovy_trh/kurzy_devizoveho_trhu/denni_kurz.txt?date=17.06.201
Test script:
---------------
The issue have appeared on the production server. I have immediately
downgraded to PHP 7.1.5 so I have no test script available.
Expected result:
----------------
The PHP behavior is the same for both 7.1.5 and 7.1.6 in this case.
Actual result:
--------------
An error message started to be thrown in 7.1.6.
--
Edit bug report at https://bugs.php.net/bug.php?id=74774&edit=1
--
Try a snapshot (PHP 5.4): https://bugs.php.net/fix.php?id=74774&r=trysnapshot54
Try a snapshot (PHP 5.5): https://bugs.php.net/fix.php?id=74774&r=trysnapshot55
Try a snapshot (trunk): https://bugs.php.net/fix.php?id=74774&r=trysnapshottrunk
Fixed in SVN: https://bugs.php.net/fix.php?id=74774&r=fixed
Fixed in release: https://bugs.php.net/fix.php?id=74774&r=alreadyfixed
Need backtrace: https://bugs.php.net/fix.php?id=74774&r=needtrace
Need Reproduce Script: https://bugs.php.net/fix.php?id=74774&r=needscript
Try newer version: https://bugs.php.net/fix.php?id=74774&r=oldversion
Not developer issue: https://bugs.php.net/fix.php?id=74774&r=support
Expected behavior: https://bugs.php.net/fix.php?id=74774&r=notwrong
Not enough info: https://bugs.php.net/fix.php?id=74774&r=notenoughinfo
Submitted twice: https://bugs.php.net/fix.php?id=74774&r=submittedtwice
register_globals: https://bugs.php.net/fix.php?id=74774&r=globals
PHP 4 support discontinued: https://bugs.php.net/fix.php?id=74774&r=php4
Daylight Savings: https://bugs.php.net/fix.php?id=74774&r=dst
IIS Stability: https://bugs.php.net/fix.php?id=74774&r=isapi
Install GNU Sed: https://bugs.php.net/fix.php?id=74774&r=gnused
Floating point limitations: https://bugs.php.net/fix.php?id=74774&r=float
No Zend Extensions: https://bugs.php.net/fix.php?id=74774&r=nozend
MySQL Configuration Error: https://bugs.php.net/fix.php?id=74774&r=mysqlcfg