#3482 [Opn->]: Max Upload Filesize not working.

From: Date: Tue, 01 Oct 2002 16:41:28 +0000
Subject: #3482 [Opn->]: Max Upload Filesize not working.
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-20962@lists.php.net to get a copy of this message
ID: 3482 Updated by: hholzgra@php.net Reported By: dph@nw.verio.net -Status: Open +Status: Won't fix Bug Type: Misbehaving function Operating System: FreeBSD 2.2.8 PHP Version: 3.0.14 New Comment: We are sorry, but can not support PHP 3 related problems anymore. Momentum is gathering for PHP 5, and we think supporting PHP 3 will lead to a waste of resources which we want to put into getting PHP 5 ready. Ofcourse PHP 4 will will continue to be supported for the forseeable future. up to php 4.1.2 an uploaded file has to fit into ram for a short while before being written back to disk. so upload size is not only limited by max_upload_size but also by memory_limit, ulimit settings for the webserver process and by the total amount of ram and swapspace... beginning with php 4.2 uploaded files are streamed through to the filesystem without being completely buffered in memory, so uploads are now limited by max_upload_size only Previous Comments: ------------------------------------------------------------------------ [2000-02-14 20:57:53] dph@nw.verio.net Attempting to upload a file larger than 25mb with PHP 3.0.14 fails with this error in the logs: FATAL: emalloc(): Unable to allocate 26445703 bytes I have verified with phpinfo() that php.ini is being read and is reporting a max file size of 500 mb! In re-compiling Apache with 3.0.10 and 3.0.5 has not affected a problem. The only thing that has remained constant is an upgrade from Apache 1.3.3 to 1.3.9. http://www.expresscopy.com/phpinfo.php3 ------------------------------------------------------------------------ -- Edit this bug report at http://bugs.php.net/?id=3482&edit=1

« previous php.bugs (#20962) next »