#10571 [Com]: blank browser with Xitami
| From: | costati at tin dot it | Date: | Tue, 01 Oct 2002 18:32:52 +0000 |
| Subject: | #10571 [Com]: blank browser with Xitami | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-21023@lists.php.net to get a copy of this message | ||
ID: 10571
Comment by: costati@tin.it
Reported By: nigglefish@hotmail.com
Status: Closed
Bug Type: Other web server
Operating System: win2000
PHP Version: 4.0.4pl1
New Comment:
I had the same problem. This is how I solved.
If your PHP has been compiled with FORCE_CGI_DIRECT, you have to leave
blank doc_root in php.ini and uncomment the line:
cgi.force_redirect=1
In php.ini set cgi.redirect_status_env to an environment variable name,
eg PHPON.
cgi.redirect_status_env=PHPON;
In autoexec.bat set the environment var to any value.
eg add the line:
set PHPON yes
Also in autoexec.bat remember to add your PHP installation (eg c:\php)
to the path.
tito
Previous Comments:
------------------------------------------------------------------------
[2001-07-23 18:38:05] andy@php.net
no feedback after 30 days.
------------------------------------------------------------------------
[2001-06-23 14:55:41] sniper@php.net
Does this happen with PHP 4.0.6 ?
------------------------------------------------------------------------
[2001-05-01 01:04:17] nigglefish@hotmail.com
I am running a Xitami (v2.4c1) server on win2000.
I used the install shield to install PHP 4.0.4.
All the filters and stuff seem to be set up right in Xitami. I have
installed and used PHP 3 with the same server and followed the same
steps to configure it for PHP 4.
I have set the "doc_root" in the php.ini file to "C:\Nigel\VWS".
However, when I run a script nothing happens: I get a blank browser
screen. Setting the "display_startup_errors" in the php.ini file I get
the message:
"Fatal error: Unable to open C:\Nigel\VWS\ in Unknown on line 0"
I tried commenting out the "doc_root" setting in the php.ini file and I
get the same error only it's pointing to the cgi-bin directory of
Xitami (even though I have told it to use "c:\Nigel\VSM\" for files).
I tried pointing the "doc_root" to the complete path of the php script
file including it's filename and that worked and processed the file
normally... every time the server started up php for any page.
I really am stumped. Thanks in advance.
------------------------------------------------------------------------
[2001-05-01 01:02:02] nigglefish@hotmail.com
I am running a Xitami (v2.4c1) server on win2000.
I used the install shield to install PHP 4.0.4.
All the filters and stuff seem to be set up right in Xitami. I have
installed and used PHP 3 with the same server and followed the same
steps to configure it for PHP 4.
I have set the "doc_root" in the php.ini file to "C:\Nigel\VWS".
However, when I run a script nothing happens: I get a blank browser
screen. Setting the "display_startup_errors" in the php.ini file I get
the message:
"Fatal error: Unable to open C:\Nigel\VWS\ in Unknown on line 0"
I tried commenting out the "doc_root" setting in the php.ini file and I
get the same error only it's pointing to the cgi-bin directory of
Xitami (even though I have told it to use "c:\Nigel\VSM\" for files).
I tried pointing the "doc_root" to the complete path of the php script
file including it's filename and that worked and processed the file
normally... every time the server started up php for any page.
I really am stumped. Thanks in advance.
------------------------------------------------------------------------
[2001-05-01 00:45:21] cnewbill@php.net
Not enough information.
See http://www.php.net/bugs-dos-and-donts.php
-Chris
------------------------------------------------------------------------
The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at
http://bugs.php.net/10571
--
Edit this bug report at http://bugs.php.net/?id=10571&edit=1