#3781 [Opn->]: Cannot load /libexec/libphp3.so
| From: | hholzgra@php.net | Date: | Tue, 01 Oct 2002 18:40:38 +0000 |
| Subject: | #3781 [Opn->]: Cannot load /libexec/libphp3.so | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-21030@lists.php.net to get a copy of this message | ||
ID: 3781
Updated by: hholzgra@php.net
Reported By: meng@dbai.tuwien.ac.at
-Status: Open
+Status: Won\'t fix
Bug Type: Dynamic loading related
Operating System: SPARC/Solaris 2.6
PHP Version: 3.0.14
New Comment:
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.
Previous Comments:
------------------------------------------------------------------------
[2000-03-09 05:55:32] meng@dbai.tuwien.ac.at
we use:
Apache 1.3.11
Mysql 3.23.10-alpha
SPARC/Solaris 2.6
GCC 2.95.2
Sun ld
apachectl start occures the following error:
Syntax error on line 207 of /sw/web/conf/httpd.conf:
Cannot load /sw/web/libexec/libphp3.so into server: ld.so.1:
/sw/web/bin/httpd: fatal: relocation error: file
/sw/web/libexec/libphp3.so: symbol __eprintf: referenced symbol not
found
apachectl start: httpd could not be started
with ../libexec/libphp3.so there are no unresolved references
the apache configure is:
./configure --prefix=/sw/web --enable-module=info
--enable-module=rewrite --enable-module=speling --enable-module=so
the php configure is:
./configure --prefix=/sw/web --with-mysql=/sw/web
--with-apxs=/sw/web/bin/apxs --with-xml
the mysql configure is:
./configure --prefix=/sw/web --enable-shared=no
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=3781&edit=1