#4260 [Opn->]: configure script appears to correctly build for --with-ldap or --with-mysql
| From: | hholzgra@php.net | Date: | Tue, 01 Oct 2002 19:48:47 +0000 |
| Subject: | #4260 [Opn->]: configure script appears to correctly build for --with-ldap or --with-mysql | ||
| References: | 1 | Groups: | php.bugs |
| Request: | Send a blank email to php-bugs+get-21095@lists.php.net to get a copy of this message | ||
ID: 4260
Updated by: hholzgra@php.net
Reported By: steve.lewis@iname.com
-Status: Open
+Status: Won\'t fix
Bug Type: Installation problem
Operating System: Solaris 2.8
PHP Version: 3.0.16
New Comment:
We are sorry, but can not support PHP 3 related problems anymore.
Momentum is gathering for PHP 5, and we think supporting PHP 3 will
lead to a waste of resources which we want to put into getting PHP 5
ready. Ofcourse PHP 4 will will continue to be supported for the
forseeable future.
Previous Comments:
------------------------------------------------------------------------
[2000-04-27 10:38:54] steve.lewis@iname.com
of course, that should read
"configure script appears to incorrectly build...."
------------------------------------------------------------------------
[2000-04-27 09:42:58] steve.lewis@iname.com
configure appears to fail to put correct -l options in APXS_LDFLAGS for
--with-ldap and --with-mysql, details below;
apache 1.3.12 with DSO
php-3.0.16
openldap 1.2.9
mysql 3.22.32
built php-3.0.16 with
./configure --with-apxs=/usr/local/apache/bin/apxs --with-xml \
--with-ldap=/usr/local --with-config-file-path=/usr/local/apache
build and install appears to complete successfully, however apache
(1.3.12)
will not start, error message is
Cannot load /usr/local/apache/libexec/libphp3.so into server: ld.so.1:
/usr/loca
l/apache/bin/httpd: fatal: relocation error: file
/usr/local/apache/libexec/libp
hp3.so: symbol ber_free: referenced symbol not found
workaround appears to be to add -llber to APXS_LDFLAGS in Makefile
after configure.
A similar problem occurs for mysql, adding -lmysqlclient to
APXS_LDFLAGS appears
to fix it.
a quick look at configure.in suggests these should be added
automatically, beyond
my knowledge to see why they are not.
a copy of my environment below;
$ set
HOME=/export/home/slewis
HZ=100
IFS=
LC_COLLATE=en_GB.ISO8859-1
LC_CTYPE=en_GB.ISO8859-1
LC_MESSAGES=C
LC_MONETARY=en_GB.ISO8859-1
LC_NUMERIC=en_GB.ISO8859-1
LC_TIME=en_GB.ISO8859-1
LOGNAME=slewis
MAIL=/var/mail/slewis
MAILCHECK=600
MANPATH=/usr/local/man:
OPTIND=1
PATH=/usr/local/bin:/usr/bin:/usr/ucb:/etc:.:/usr/ccs/bin
PS1=$
PS2=>
SHELL=/bin/sh
TERM=vt220
TZ=GB
_INIT_NET_STRATEGY=none
_INIT_PREV_LEVEL=S
_INIT_RUN_LEVEL=3
_INIT_RUN_NPREV=0
_INIT_UTS_ISA=i386
_INIT_UTS_MACHINE=i86pc
_INIT_UTS_NODENAME=calvin
_INIT_UTS_PLATFORM=i86pc
_INIT_UTS_RELEASE=5.8
_INIT_UTS_SYSNAME=SunOS
_INIT_UTS_VERSION=Generic
------------------------------------------------------------------------
--
Edit this bug report at http://bugs.php.net/?id=4260&edit=1