Bug #74185 [Com]: PHP periodically failing to populate superglobals

From: Date: Tue, 12 Sep 2017 18:20:02 +0000
Subject: Bug #74185 [Com]: PHP periodically failing to populate superglobals
References: 1  Groups: php.bugs 
Request: Send a blank email to php-bugs+get-211104@lists.php.net to get a copy of this message
Edit report at https://bugs.php.net/bug.php?id=74185&edit=1

 ID:                 74185
 Comment by:         jamwhitl at cisco dot com
 Reported by:        robin at willowsv dot com
 Summary:            PHP periodically failing to populate superglobals
 Status:             Closed
 Type:               Bug
 Package:            Variables related
 Operating System:   Windows 7
 PHP Version:        7.1.2
 Assigned To:        ab
 Block user comment: N
 Private report:     N

 New Comment:

It's not fixed.  I've have 7.1.8 on two development servers and a production sever.  The
problem is random with, anywhere from 2 hours to a week after apache is restarted. Extensive testing
has indicated the problem is with other superglobals like $_POST and $_SESSION as well.  Restating
Apache always resolves it, but that's not an acceptable solution in a production environment. 
I think this bug should be reopened, or at least a new one opened.


Previous Comments:
------------------------------------------------------------------------
[2017-09-12 17:38:09] ab@php.net

It is fixed in 7.2. It would be great the pre releases could be tested therefore.

Thanks.

------------------------------------------------------------------------
[2017-09-12 17:08:49] a dot gurevicius at gmail dot com

So, has this been fixed in any php 7 version? I've just got the same problem on Windows php
7.1.8. The $_GET superglobal is NULL, while $_REQUEST is ok. Restarting Apache solved the problem,
but it keeps coming back. Is there anything that can be done?

------------------------------------------------------------------------
[2017-09-12 02:30:50] jamwhitl at cisco dot com

This also happens on $_REQUEST on all versions of PHP7.  I’ve been experiencing this problem
since 7 came out.  I’m still using 5.6.29 because of it.  Windows server 2008 R2 with Apache
2.4.25/27.

------------------------------------------------------------------------
[2017-04-02 01:02:02] ab@php.net

Related To: Bug #73554

------------------------------------------------------------------------
[2017-03-31 11:12:15] robin at willowsv dot com

I see

Now on php-master-ts-windows-vc14-x86-r6574d9f.zip

Reported as 7.2.0-dev

------------------------------------------------------------------------


The remainder of the comments for this report are too long. To view
the rest of the comments, please view the bug report online at

    https://bugs.php.net/bug.php?id=74185


--
Edit this bug report at https://bugs.php.net/bug.php?id=74185&edit=1


Thread (21 messages)

« previous php.bugs (#211104) next »